I got a new Crucial M4 128 GB Sata 3 solid state drive that i cloned my OS on to. I have a laptop with two 500 GB drives, one holding the OS and one holding data. I swap the os drive with the SSD and i get an error on boot "BOOTMGR is Missing". I tried loading from a system restore disk and when it loads it does not show the OS on the SSD in the list of OS when it first loads.

tried the following commands in cmd:


BOOTREC /FIXBOOT - element not found

BOOTREC /REBUILDBCD - finds os but when i try to enter Y or Yes to add to boot list it returns element not found


I also used diskpart to make sure the partition is active on the drive so i am at a loss for what else can be done to make it work.

My laptop is an Asus G72GX if that makes any difference.

  • 1
    It sounds like you copied the wrong hdd.
    – Ramhound
    Aug 28, 2012 at 13:02
  • no i copied the right one, all the OS files are on the drive when i connect it via USB. And both BOOTREC /REBUILDBCD and BOOTREC /SCANOS see the OS as well.
    – jardane
    Aug 28, 2012 at 13:07
  • How exactly did you "Clone" it? Aug 28, 2012 at 13:13
  • i used a program called "EaseUS Partition Master"
    – jardane
    Aug 28, 2012 at 13:27

2 Answers 2


I was in a similar situation after cloning a hard drive to an SSD. The annoying part is that when I had both disks in the system, it would still boot to the old disk--independent of the boot sequence, but only if I had the windows repair disk in the CD drive (or maybe any CD, not sure).

The cure that worked for me was to use a Windows Repair disk with the older original drive physically disconnected from the system. Just boot into Windows Repair, choose the OP system and use the "Repair Startup" to write a new BCD automatically. Worked great once I had the guts to try it. (I had try'ed numerous times with the org disk still in the drive but it was causing drive letter to be wrong or writing to the wrong place because it would never work.)

I was then able to put the original disk back in the system and it boots fine now. I believe there are physically two copies of the BCD now and if either of my disks is removed I think it will start. Kind of neat. Some may argue saying its not possible but the facts are leaning the other way.


I used EaseUS to clone a hard drive and I ran into the same issues. I tried using the Windows 7 Install disk to repair the cloned hard drive's boot options, but without success. I tried all 4 of the BOOTREC options and got the exact same responses as jardane did.

What I ended up doing to resolve the issue is that I used a copy of a GParted Live CD to boot the system. Once I had GParted running, I right clicked on my cloned hard drive's partition and selected the "Manage Flags" option. I then checked the flag for "Boot". After that, I restarted the computer and went into the repair option area from the Windows 7 install disc. It prompted me that there were problems with the boot configuration, and requested permission to fix the problems. I said okay and then it restarted. At that point, it still didn't work. I went back into the Windows 7 install disc repair options again and this time it saw my OS and I selected the startup repair option. Once that was finished, the computer rebooted and then successfully booted into my cloned drive.

I think the reason I had problems in the first place may be because I didn't toggle an option to make it a boot disc or something when I was cloning it. However, going back I don't see which option might have allowed it to work correctly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .