115

I have a .bash_profile in my home directory, but it isn't getting run on login. If I do the following, then things seem to be as I expect:

ssh myhost
bash
source ~/.bash_profile

But normally that all happens on login. Thoughts?

  • 3
    Also make sure that you don't have a ~/.profile or ~/.bash_login, as only one of the three is sourced. (I forgot the exact order.) – user1686 Sep 25 '09 at 15:20
  • 3
    Why do you have a different question in the title and different one in the body of your post? – pabouk Nov 9 '13 at 10:25
189

Use:

chsh

Enter your password and state the path to the shell you want to use.

For Bash that would be /bin/bash. For Zsh that would be /usr/bin/zsh.

| improve this answer | |
  • 15
    +1 - not sure why the OP decided that editing the password file was a better choice, but this is the best answer – kdgregory Sep 25 '09 at 12:51
  • 1
    Yeah beat me to it, this is the standard way. – John T Sep 25 '09 at 13:49
  • 1
    And on ubuntu the path to the shell you want to use is... /bin/bash (and /bin/sh is not the same) – Harry Wood Mar 2 '12 at 1:01
  • 51
    Or you can use sudo chsh -s /bin/bash username – Oleg Vaskevich Jan 21 '14 at 4:03
  • 10
    You must log out and log back in to see this change. – Neil Traft Jul 6 '14 at 21:59
39

On top of akira's answer, you can also edit your /etc/passwd file to specify your default shell.

You will find a line like this example:

john:x:1000:1000:john,,,:/home/john:/bin/sh

The shell is specified at the end.

| improve this answer | |
  • 8
    Better to use the 'chsh' command as suggested by akira -- less chance to screw something up by mistake. – Lars Haugseth Sep 25 '09 at 13:17
  • 5
    not to mention 'chsh' is available when you can't write to /etc/passwd – quack quixote Oct 7 '09 at 11:30
  • 1
    But if you so have access to modifying the /etc/passwd and you're careful, John's answer is making good use of the tools the system provides. – AJP Apr 26 '14 at 11:00
  • 4
    You must log out and log back in to see this change. – Neil Traft Jul 6 '14 at 22:01
  • 2
    If you're running a server without user passwords - providing access only through public/private ssh keys ... it also makes a lot of sense. chsh requires a password. – Keith John Hutchison Sep 10 '15 at 2:42
7

Enable bash:

$ /bin/bash

Change shell for user:

$ sudo usermod -s /bin/bash username

where:

  -s, --shell SHELL             new login shell for the user account
| improve this answer | |
  • 2
    (1) What do you mean by “enable bash”? (2) The user wants to change his own login shell on a remote system.  Why do you assume that he has sudo access on that system?  Why do you provide instructions in terms of changing another user’s login shell? – G-Man Says 'Reinstate Monica' Jan 26 '18 at 3:24
  • 1
    Using chsh (as suggested above) did not work for me. This command did! – Per Lindberg Feb 12 '19 at 9:30
6

You might check your terminal program. It might be configured to run /bin/sh rather than /bin/bash

Bash executes .bash_profile only for login sessions. .bashrc is executed for all bash sessions, not only login sessions. Try sourcing .bash_profile from .bashrc (avoid circular dependency!) or configuring your terminal program to run /bin/bash -l as a shell program.

| improve this answer | |
  • 2
    terminal program has nothing to do with the problem because it is the sshd on the remote machine, which spawns the new shell. – akira Sep 26 '09 at 4:31
4

To make any shell your default, first verify it is installed and recognized on your computer by looking at the contents of /etc/shells:

$ cat /etc/shells
# /etc/shells: valid login shells
/bin/sh
/bin/bash
/usr/bin/bash
/bin/rbash
/usr/bin/rbash
/bin/dash
/usr/bin/dash
/usr/bin/fish

Then use chsh to change your shell:

$ sudo chsh -s /usr/bin/bash $(whoami) # or sudo chsh -s /bin/bash $(whoami)

References

  1. https://linux.die.net/man/1/cat
  2. https://linux.die.net/man/1/whoami
  3. https://linux.die.net/man/5/shells
  4. https://linux.die.net/man/1/chsh
| improve this answer | |
3

One alternative is to rename your startup script into .profile. This file is being source by most Unix shells.

| improve this answer | |
1

If you somehow don't see your username in the /etc/passwd file [this is the case when your system is under control of some other domain e.g. in IT companies] Or it says "user not found" with chsh option than below process might help you.

The logic behind the below trick -> On Ubuntu, /bin/sh is dash. You can switch your system to using bash. On Ubuntu, /bin/sh is a symbolic link to dash. You can make it a symbolic link to bash instead.To change it, run

sudo dpkg-reconfigure dash

And press No to switch to bash.

Now, go to Terminal->Edit->preferences->Command and tick the checkbox with statement

Run command as login shell

And that's it.

| improve this answer | |
0

There's not enough information in your question for me to say for sure, but I've hit the same problem before. Assuming you've already get /bin/bash set in your password entry, it may be the way your terminal launches.

If you're trying to launch a GUI terminal, say gnome-terminal you may be expecting the shell to read your bash startup files. However, this doesn't happen on Ubuntu and maybe other systems by default.

The way I've fixed it on Ubuntu is to edit the gnome-terminal preferences, and set the startup command to be bash -l. -l is short for --login. This tells bash to startup as as login shell, which causes it to load the startup scripts as you get when logging in via ssh.

I'm sure there's a good rationale for this being the way it is, but I found it surprising and a more than a bit annoying as I share the same profiles across linux, cywgin and macos systems.

| improve this answer | |
0

I had this same error, and the above answers did not work for me. For some reason my shell was still loading as just /bin/sh instead of /bin/bash and I have the command to in my .profile as it is supposed to be in Ubuntu 16.04 but I also have a blank .bash_profile file that appears to be being read by .bashrc instead of .profile.

So to get everything to work I simply added the command I needed to launch into my .bash_profile file and then everything worked on next ssh.

So I would say if you have all three files: .bashrc, .bash_profile, .profile make sure your .bash_profile file has stuff in it you want to load on login to the shell environment.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.