10

I edited /etc/apt/source.list to have restricted and partner repository, but the results always:

sudo apt-get install libfaac-dev ....
....
E: Unable to locate package libfaac-dev

The package is used by audio codecs, and ffmpeg uses it.

2
  • On my Ubuntu desktop 11.04 Natty it will install without any trouble. Try change the source server maybe?
    – lllluuukke
    Aug 29 '12 at 2:07
  • what version of ubuntu you are using?
    – ji-ruh
    Jun 16 '16 at 5:39
15

libfaac-dev is in multiverse repository. So, you need to edit /etc/apt/sources.list to include multiverse repository as well. deb http://archive.ubuntu.com/ubuntu natty main restricted universe multiverse

After you change it, run the following command to install libfaac-dev:

sudo apt-get update && sudo apt-get install libfaac-dev
8

This problem was KILLING me but I figured it out. It turns out that I needed to add the following lines in my /etc/apt/sources.list:

deb http://us.archive.ubuntu.com/ubuntu/ precise-updates multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-updates multiverse

Meaning that, for the multiverse, you should have 4 lines in total:

deb http://us.archive.ubuntu.com/ubuntu/ precise multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise multiverse
deb http://us.archive.ubuntu.com/ubuntu/ precise-updates multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-updates multiverse
0

Try to compile it

$ wget -O fdk-aac.tar.gz https://github.com/mstorsjo/fdk-aac/tarball/master
$ tar xzvf fdk-aac.tar.gz
$ cd mstorsjo-fdk-aac*
$ autoreconf -fiv
$ ./configure --prefix="$HOME" --disable-shared
$ make
$ make install

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.