2

I have been using Google to find a solution as to why guest (ubuntu) can't access internet. Host system is Windows XP. None of the solution didn't work for me. Solutions that worked for others: 1. Enabling NAT 2. Enabling shared internet connection

I think the problem is that my host and guest use by default different subnet masks (respectively 255.255.0.0 vs 255.255.255.0) assigned by DHCP. Configuring the guest manually to use the same subnet mask doesn't seem to help either. I guess I configured it incorrectly.

  • Proxy wasn't configured. – inzzz Sep 10 '12 at 11:37
2

Try setting VM to use Host-Only connection and then set up Windows to share your current connection (the one you are using now for internet) with connection VMnet1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.