I have a Windows XP desktop and a Windows 7 laptop both connected to a TrendNET TEW-432BRP router, which is connected to the Internet. They both have static IPs. The desktop has an external hard drive connected to it. The laptop is wireless and the desktop is wired.

I enabled sharing on the external hard drive about two years ago when I bought it. I mapped it as a network drive on the laptop. I think it was yesterday, the laptop just stopped recognizing any of the computers on my network (When I open network, my laptop's the only one on it). I also get an error message "An error occurred while connecting A: to \CERTIFIED-DATA\Expansion Microsoft Windows Network: The network path was not found. The connection has not been restored" when I try to connect to the network drive.

Both computers run Avast, and there hasn't been any problems with it.

This has happened before but I never figured out why and how to fix it. It's usually fixed when I reinstall the OS of the affected system.


I can't navigate the computer using \\CERTIFIED-DATA. I get a message saying "Windows cannot access \CERTIFIED-DATA. Check the spelling of the name, Otherwise, there might be a problem with your network"

I clicked diagnose on the message and it failed to find anything wrong

I clicked diagnose on my wireless connection, and it just keeps trying to check if something is wrong with the connection

I can ping it successfully

Update 2: I can see the computers on my network, but I still get the same message when I click on them

  • When this happens, can you navigate to the share via UNC path? Does the machine respond to Ping? What have you tried already? – Ƭᴇcʜιᴇ007 Aug 31 '12 at 17:28
  • @techie007 Sorry, it's added now – Alex Aug 31 '12 at 17:34
  • Is the Certified-Data machine on and not asleep? If you reboot either/both of the machines, does it start working again? – Ƭᴇcʜιᴇ007 Aug 31 '12 at 17:38
  • It's on, and I tried rebooting them both. It hasn't worked since yesterday. Or maybe it was the day before, but it was very recent – Alex Aug 31 '12 at 17:47
  • 1
    can you navigate to it's IP address? e.g. \\ – SeanC Aug 31 '12 at 19:35

Verify that "Client for Microsoft Networks" is enabled on your Network Connection.

Start-> Settings -> Network Connections

Right Click your "Local Area connection"

Click properties

Verify that "Client for Microsoft Networks" is Checked

  • It's enabled on all of the connections – Alex Aug 31 '12 at 23:14

It turns out the service TCP/IP NetBIOS Helper needs to be enabled

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.