Hi I was using ADSL Modem/Router earlier. The device is quite old Pronet PN-ADSL 101 E/U model. I bought new Wireless Router TPLink TL-WR941ND.

I configured my old router in bridge. Now, if I have to connect my pc to Internet through the old router.

Then I connected the RJ45 output of old router to the WAN in of new router. and ran the CD of new router. It configured the new router. So now I have to just plug in the wires in my new routers any RJ45 out.

I am able to access the Internet when I connect through new router, but some sites are getting blocked. These sites work perfectly fine when I connect my pc directly to my old router.

A friend said he also faced same problem.
Surprisingly he advised me to see if the same websites will work through Opera turbo mode and boom they worked.

So what could be the problem?


I solved this problem. I checked the MTU size for my old router using following command:

netsh interface ipv4 show subinterfaces

Then I set the same MTU size for my new router and it started working. By default it was 1480. But my old router's MTU was 1460. MTU size is very dependent on your ISP and network backbone. So it has to match up.

  • I wrote a post explaining the whole thing for noobs in my blog - bit.ly/O2MKYr – Maha Sep 1 '12 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.