When I try to lunch my MacBook Pro I can see a progress bar on loading screen. It goes to 1/15 or something like this and then it shut downs - I cannot reach even login screen. It happened to me 2 months ago, I have 'fixed' this by formatting my hard drive and installing OSX (Lion) again.
This time I think that situation is a little bit different - I am able to enter single-user mode by pressing cmd + s. I then type /sbin/fsck -yf, I get the error:

** Checking Journaled HFS Plus volume.
   The volume name is Macintosh HD
** Checking extents overflow file.
** Checking catalog file.
   Invalid node structure
(4, 24704)
** The volume Macintosh HD could not be verified completely.
/dev/rdisk0s2 (hfs) EXITED WITH SIGNAL 8

but when I type exit, I can the login screen and I can log in. I tried a lot of things, booting from recovery partition and choosing disk utility to repair the disc, but I get error that it cannot be repaired. I have googled for hours and the only real solution I have found was to buy Disc warrior that might fix the issue. Any other suggestions?

Secondary question is what causes this issue? I thought the reason are bad sectors, but Smart Utility haven't found any. I found suggestion that RAM could cause this kind of issue as well, so I downloaded rember and made memory test - all tests passed. Right now I have used my solution of entering single-mode user and then typing exit, however I am not sure how long it will 'work'. Of course I have back-uped what I considered important.

Thanks for the help in advance!

UPDATE: I guess Smart Utility was not very useful, I mnaged to get input/output error, which I believe is equivalent to bad sector.


I've personally ran into a similar (if not the same) situation some time ago. I cannot say for certain what exactly causes the issue as it seemed to have happened out of the blue for me, couldn't say for sure I did anything to trigger the problem (the only thing I suspected was installing a Kext for some research I was doing...)

I fixed the problem by getting a Live CD with OS X and used Disk Warrior to scan the drive. I looked for several other options but nothing seemed to work and reformatting was not an option. Disk Utility didn't do anything either, it just said I should reformat the drive. I haven't had a problem with the drive since then though.

The only thing that seems different from your problem is the fact that OS X would boot for me after waiting 30 minutes for it to scan the drive and confirm that there's a problem.

Hope this bit of information helps you in any way. Good Luck!

  • Thanks, I have actually solved the issue without Disk Warrior! Unfortunately I have no idea what helped me - I have downloaded smartnotools to test my disc for bad sectors, I have found input/output error while trying to launch Skype and I have deleted its directory and then reinstall skype, I tried once more disk utils. I had to do 3x verify/repair combo and after the third time I got message that my issues have been fixed. The next verify reported no errors – mkk Sep 1 '12 at 18:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.