I recently purchased a TI-84 Plus graphing calculator, and I'm trying install the TI Connect software in order to connect the calculator to my computer via the USB cable. Unfortunately, I'm getting this error while trying to install the program:

Error 1303. The installation has insufficient privileges to access this directory: E:\Data\Timothy\Documents\MyTIData. The installation cannot continue. Log on as administrator or contact your system administrator.

However, my account is the only account on my PC, and it has administrative privileges. I've also tried running the installer with Run as Administrator, but with no luck. If I create the folder MyTIData manually, I receive this error:

Error 1317. An error occurred while attempting to create the directory: E:\Data\Timothy\Documents\MyTIData

I've reapplied the security settings to the E:\Data folder (and all its sub-directories) to Full for my account. I've also gone into Computer Management, and given SYSTEM full privileges for the entire disk. I've also logged out, logged back in, restarted, etc. but still, no luck.

Now, I should mention that my Documents folder is not at the default location. I changed it due to my C: disk being a 90GB SSD, so I moved all my personal data onto the extra storage disk (which is ~1TB). I don't know if that is causing the issue, but it can't hurt throwing it out there.

So why can't I install this program? Google'ing the problem brings up this error for various other installers (such as Visual Studio and Microsoft Office), but nothing for TI Connect. All the solutions are the same: Give the folder Full privileges...but I've already done this! I've also tried running the installer with and without the calculator plugged in, but it didn't change anything. In the prompt that contains the error, repeatedly clicking Retry or waiting a few moments before clicking Retry also produces no result.

  • Can you install it in the default directory? – Phillip R. Sep 1 '12 at 20:35
  • @PhillipR. I am installing it to the default directory. It doesn't let you choose where to put MyTIData. – smoth190 Sep 2 '12 at 0:00

Ok, I seemed to have solved the problem. It seems that although my actual Documents folder was on the E: drive, the system thinks of it on the C: drive (because I simply changed its location, I guess). When I gave SYSTEM full privileges to the entire E: drive, it didn't give full privileges to the Documents folder. I created MyTIData, and added SYSTEM to the access privileges list, and gave it Full access. After this, the install continued without error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.