12

I have set the Mail app from Microsoft (WinRT) as the default application for mail in Default Programs. However, when I right-click on a file, and select Send to > Mail recipient I get a message box saying:
There is no email program associated to perform the requested action. Please install an email program or, if one is already installed, create an association in the Default Programs control panel.

Is there a way to get this action working with Mail?

8
+50

The Send to ... Mail Recipient uses the MAPI\Send Mail association, or the Send mail command.

enter image description here

The Microsoft Mail app only contains an association for the MAILTO protocol, so you can't set it as a recipient of the Send mail command.

enter image description here

  • Yes. If you have Outlook or Live Mail installed, it will hook into those programs. It's odd, and one of those omissions in the Mail app that people complain about. However, it's just the way things stand, right now. – Ben Richards Mar 18 '13 at 19:38
3

If like me you are having this issue trying to send photos from from desktop explorer to an Outlook recipient in Windows 8.1 / Office 365. Use this link but be sure to use 'Joseph's Script' it's an easy fix. Hope this helps somebody.

Thanks to Slipstick Systems for saving me another day of searching forums for the answer.

http://www.slipstick.com/outlook/create-a-custom-send-to-shortcut/

Joseph’s method uses a windows script and allows you to select multiple files and attach them to a new message, preserving your signature and stationery settings.

To use, open Notepad then copy this code and paste it in to notepad. Save it as SendToMailRecipient.vbs. You can either save it in the SendTo folder or save it elsewhere and create a shortcut to it to place in the SendTo folder.

Option Explicit
Dim objArgs, OutApp, oNameSpace, oInbox, oEmailItem, olMailItem
Dim a, oAttachments, subjectStr, olFormatHTML
olMailItem = 0
olFormatHTML = 2
Set objArgs = WScript.Arguments 'gets paths of selected files
Set OutApp = CreateObject("Outlook.Application") 'opens Outlook
Set oEmailItem = OutApp.CreateItem(olMailItem) 'opens new email
For a = 0 to objArgs.Count - 1
Set oAttachments = oEmailItem.Attachments.Add(objArgs(a))
subjectStr = subjectStr & Right(objArgs(a),Len(objArgs(a))-(InStrRev(objArgs(a),"\"))) & ", " 'recreates the default Subject e.g. Emailing: file1.doc, file2.xls
Next
If subjectStr = "" then subjectStr = "No Subject "
oEmailItem.Subject = "Emailing: " & Left(subjectStr, (Len(subjectStr)-2))
oEmailItem.BodyFormat = olFormatHTML
oEmailItem.Display

By the way hit the windows key+R and enter " shell:sendto " to take you straight to the folder where you will need to save the file, be sure to use the right file extension (not txt) it's all in the instructions on the link above.

2

Wild idea : I wonder if this is a case of a metro app not available from the desktop.

If this is the case, you would need another mail client.

1

Have you set it up as the default program?

  • Click on start -> Default Programs.
  • Then select Set program access and computer defaults.
  • Then click Custom and select your default e-mail.
  • Yes, that was the first thing I checked. – Louis Sep 3 '12 at 17:44
1

I had a somewhat related problem registering a program to handle the MAPI "Send Mail" command, and here are the Registry changes that fixed it for me.

I was trying to make Opera Mail my default email program. It was already registered to handle URLs with the mailto scheme, but I still couldn't use File > Save & Send > Send Using E-mail > Send as Attachment in Office programs without getting the error message you mentioned. Sadly, when I tried to use Default Programs > Set Default Programs from the Control Protocol to associate Opera Mail with MAP Send Mail, Opera Mail did not appear in the programs list. It's not a Metro application, but some registry entries must be missing.

To solve this, I edited the SOFTWARE\Clients\Mail keys in the Registry:

HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\OperaMail

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\OperaMail]
@="OperaMail"
"DLLPath"="C:\\Programs\\Internet\\Opera Mail\\mapi\\OperaMAPI.dll"
"LocalizedString"="OperaMail"

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\OperaMail\DefaultIcon]
@="C:\\Programs\\Internet\\Opera Mail\\OperaMail.exe,3"

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\OperaMail\InstallInfo]
"ShowIconsCommand"="\"C:\\Programs\\Internet\\Opera Mail\\OperaMail.exe\" /ShowIconsCommand"
"HideIconsCommand"="\"C:\\Programs\\Internet\\Opera Mail\\OperaMail.exe\" /HideIconsCommand"
"ReinstallCommand"="\"C:\\Programs\\Internet\\Opera Mail\\OperaMail.exe\" /ReInstallMailer"
"IconsVisible"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\OperaMail\Protocols]

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\OperaMail\Protocols\mailto]
@="URL:MailTo Protocol"
"EditFlags"=dword:00000002
"URL Protocol"=""

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\OperaMail\Protocols\mailto\DefaultIcon]
@="C:\\Programs\\Internet\\Opera Mail\\OperaMail.exe,3"

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\OperaMail\Protocols\mailto\shell]

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\OperaMail\Protocols\mailto\shell\open]

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\OperaMail\Protocols\mailto\shell\open\command]
@="\"C:\\Programs\\Internet\\Opera Mail\\OperaMail.exe\" \"%1\""

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\OperaMail\shell]

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\OperaMail\shell\open]

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\OperaMail\shell\open\command]
@="\"C:\\Programs\\Internet\\Opera Mail\\OperaMail.exe\" /Mail"

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\OperaMail\shell\properties]

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\OperaMail\shell\properties\command]
@="\"C:\\Programs\\Internet\\Opera Mail\\OperaMail.exe\" opera:config#Mail"

These already existed on my computer, I'm just including them here for completeness. I'm sure not all of these keys are necessary to get MAPI Send Mail associated correctly.

HKEY_CURRENT_USER\Software\Clients\Mail

This was the actual solution for me. Despite having all the programs correctly registered, the wrong one was selected, and the UI did not let me choose the correct one. I was finally able to choose the correct association by editing my user hive.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Clients\Mail]
@="OperaMail"

As usual, the user value overrides the machine value, which is why this was required.

  • See also reddit.com/r/operabrowser/wiki/m2tips/default_programs, which looks like the same approach. – Aldaviva Mar 22 '19 at 13:32
  • Setting HKEY_CURRENT_USER\Software\Clients\Mail to Microsoft Outlook worked, which is the name in HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook. Curiously, just setting it to Outlook worked too (previously it was set to Mozilla Thunderbird on my machine). – jmiserez Sep 10 '19 at 6:35
0

This is because you can't use metro applications from the desktop as of right now. You will either have to switch to another mail app or use a metro based file explorer to do this.

0

A user of mine had a similar issue after I upgraded them from Outlook 2010 32bit to Outlook 2016 64bit.

The issue was solved by updating Outlook via Outlook's file menu:

File > Office Account > Update Options > Update now
-1

go to dir

%appdata%\microsoft\windows\sendto

that'll show all the send to's

NOW right click

new

shortcut

browse location of your mail program . - - - example ( C:\programs\tbird )

then next

Name for shortcut. - - - example ( E-Mail To )

after you make your new "send to" shortcut. - - - example ( E-Mail To )

right click your new "send to" shortcut. - - - example ( E-Mail To )

Properties

in your Target: dir put your E-mail program. - - - example ( C:\programs\tbird.exe )

OK

now from Explorer, a right clicked file should have the proper Send to e-mail program that you named. . . . . . . thankyou !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.