Since I installed Windows 8 Preview on my personal computer, during the installation of some programs and drivers (Windows 7 ones) it started to pop me a message warning that .NET Framework 3.5 was needed:

Enter image description here

I could use "Install this feature", start to download some dependencies (300 MB) and that's it, but I don't want to have to download it every time I want to enable this feature on every machine that I install Windows 8.

Is there is some way to install .NET 3.5 on Windows 8 without having to download the entire Framework from Microsoft?

  • Is that actually what happens when you click it? In 7 and 2008 adding the "Features" or "Roles" didn't require an Internet connection to add (just to update, after adding). Including their in-built .NET version (3.5). – Ƭᴇcʜιᴇ007 Sep 3 '12 at 18:53
  • Yes, it downloads entire Framework from internet, I just checked here without internet and the service timed out. – Diogo Sep 3 '12 at 18:59
  • Wow, that's lame... then WHY is it still in the Image? :/ – Ƭᴇcʜιᴇ007 Sep 3 '12 at 19:00
  • Reference. – Diogo Sep 3 '12 at 19:02
  • I wonder if the "included" .Net 4.5 does it too then? Bizarre choices over at MS. :) Also, maybe you should reference your source in your answer (them's the rules ain't they)? :) – Ƭᴇcʜιᴇ007 Sep 3 '12 at 19:07

Yes, there is an easy way, but you must have installation media for Windows 8 (could be a DVD or even a mounted .ISO with a Windows 8 installation) and make sure the media is for the correct version of Windows (x32 or x64). Otherwise, the command line will fail (not harmful, just annoying):

  • Run a command prompt (cmd) with elevated rights ('as Administrator').
  • Run the following command:

dism.exe /online /enable-feature /featurename:NetFX3 /All /Source:E:\sources\sxs /LimitAccess

where "E:\sources\sxs" is the sxs path of your Windows 8 installation media.

Enter image description here

  • That's it, .NET 3.5 is installed on your machine. Reboot and everything that requires .NET 3.5 will work.
  • 1
    prompt me : The limitaccsess option is not recognized in this context. Dism.exe /online /enable-feature /featurename:NetFX3 /Source:I:\Sources\sxs i run that without limit-access switch, and execute successfully. – saber tabatabaee yazdi Dec 22 '12 at 9:07
  • 2
    The limitaccsess option is not recognized in this context. You can't spell limitaccess. – ta.speot.is Jul 3 '13 at 12:14

protected by Community Nov 18 '12 at 21:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.