This is first time I am trying to upgrade the RAM on my Toshiba Satellite L650 Laptop running Ubuntu 12.04 64 Bit version.

After a little research about upgrading RAM I ordered a Kingston DDR3 module and it arrived today, I just installed it and booted. Now I had a total of 6 GB of RAM, 2 GB from the module I already had and 4 GB from the Kingston module I recently got. After booting the system Everything went fine and I logged into my user account. after that I noticed that a major set of hardware was not working on my system. System was not detecting the Cooling Fan, Wireless card, Ethernet card, Bluetooth, USB ports, e-Sata, in built Card reader, web camera and possibly many more things I didn't noticed. so basically, I was left with only the LCD, keyboard, Touchpad and the in-built speakers working in place. However the total amount of RAM was updated to 6 GB as I can see it while running free.

I was wondering if I pulled some wires off the board while installing the RAM but after checking it again I realized that was not the case. So I went ahead and pulled the new module off the board and rebooted. This time everything was fine and working as always. So now, when I had the clue about the problem I tried switching the slots for modules i.e. putting the 2 GB module into the one at which the 4 GB was installed and vice versa but again after rebooting I got only the keyboard, LCD, touchpad and in-built speakers working, nothing else was working.

Again, I tried putting only the 4 GB module and booted, Same thing again, Nothing was working just the keyboard, LCD.... So finally, I inserted only the 2 GB module and booted, It was all fine now. and this new 4 GB stick that I got recently is working fine on my friend's Asus laptop running windows 7.

Now I am wondering if there is any setting in Ubuntu 12.04 that I need to modify after upgrading the RAM ? Is it limited up-to the amount of RAM presented at the time of installation ? or at least any clue about whats going on with me ?

  • Just to add more to the problem, I kept trying different experiments with it and now I noticed that none of the special function key is working i.e. Brightness control, Volume control, System lock, Hibernation, wireless switch etc. they all works while running on the 2 GB module but does not works with the 4 GB installed. – Gufran Sep 4 '12 at 3:24

finally I fixed this problem by some tricks provided here. Everything is working with the New RAM module installed.

However there was no /proc/acpi/dsdt file in my system so I copied it from /sys/firmware/acpi/tables/DSDT and proceed with dissembling it and modifying it. So, far I managed to load the custom DSDT file with GRUB but I am not sure if that is the way it should be ? I do not want to compile the kernel just for a custom DSDT.

  • You might consider "accepting" your own answer here if it did indeed work out for you. Might help people down the road if they see that there is a solution to this problem :) – JoshP Sep 17 '12 at 15:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.