Ok, so when I try to delete this from my desktop, I get this error:

enter image description here

When I click "See what's locking this" in lock hunter, I get this:

enter image description here

Now, I have a drive, called G:. I only have one physical drive, and it's D:. Also, I have NO virtual drive software installed, so I have NO clue how it got there. Right-clicking on G:\ and chosing eject doesn't do anything but change the logo, it still says the file size and whatnot. Here's the picture of the "What's locking this?" of the contained file:

enter image description here

But when I try to delete it...

enter image description here

Both of these files don't let me delete them. I had put win8install.iso as a virtual drive a while back, but I uninstalled that software (but can reinstall it if needed)

Starting this in safe mode doesn't work.

  • 1
    Did you try rebooting in Safe Mode and deleting it? – Ƭᴇcʜιᴇ007 Sep 3 '12 at 20:07
  • @techie007 that doesn't work either. – Jon Sep 3 '12 at 20:14
  • 1
    Have you mounted the ISO to a virtual CD drive? – Indrek Sep 3 '12 at 20:34
  • @Indrek no, I don't currently have any virtual CD drives installed. – Jon Sep 3 '12 at 20:44
  • 1
    @chipperyman573 : Also could you please post a screenshot by trying to unlock using Unlocker x64 in case you haven't done so? – Vrushank Oct 1 '12 at 4:17

Get a Linux Live Cd, and get gparted, systemrescue or parted magic (any release would work, but a small distro for something quick). Burn it to cd/usb, and boot your computer to it. Mount the hd, and find the folder and delete it.

You can use Unetbootin to create the live cd or do it manually.


Use Process Explorer to identify which process is keeping an open handle to the file.

  1. Click Find > Find Handle or DLL...
  2. Enter win8image.iso
  3. Click Search

Then make the program close its handle. In your case the issue might be that the ISO image is still connected to a virtual machine or a virtual drive.

  • 1
    @chipperyman573 Did you run Process Explorer "as Administrator"? – Ƭᴇcʜιᴇ007 Sep 3 '12 at 21:00
  • 1
    @AnsgarWiechers I have no virtual machine installed. – Jon Sep 4 '12 at 2:41
  • 1
    Strange. You said you have UAC enabled. Can you delete the file when you disable UAC? Also, when you run Process Explorer "as Administrator", display the lower pane (View > Show Lower Pane) and search for the handle again, can you manually close the handle (right click > Close Handle)? – Ansgar Wiechers Sep 4 '12 at 9:39
  • 1
    @chipperyman573, System means that it is loaded via a driver. You may not have it mounted as a drive-letter, but it is open with some sort of mounting program’s driver. – Synetech Sep 30 '12 at 1:17
  • 1
    @Synetech I don't have ANY mounting drivers installed. I spent two hours last night researching every driver I had installed - none of them mounted virtual drives. – Jon Sep 30 '12 at 1:21

If none software is doing the job then you can use the OLD IS GOLD formula and that is command prompt. If you want to delete the file from the running Windows then open the elevated-command prompt(command prompt window with admin rights). For this click on the start menu and then type CMD in search box and right click on the cmd.exe and then click on the option Run as Administrator.

Now open the Windows explorer and click on the Organize > Folder and Search Option.

enter image description here

Now unchecked the option Hide extension for known file types and click OK. And go to method 1 or 2.

enter image description here

To Use a Command Prompt at Boot

a. To Use a Command Prompt at Boot

b. In the command prompt, type diskpart and press Enter.

c. In the command prompt, type list volume and press Enter.

d. After making note of the drive letter, type exit and press Enter.

Method 1

To Delete a Specific File in Command Prompt

In the command prompt, type the command below and press enter.

DEL /F /S /Q /A "Full Path of File with extension"


DEL /F /S /Q /A "C:\Users\UserName\Desktop\File.txt"

File should be deleted now.

Method 2.

To Delete All Files in a Folder without Confirmation in Command Prompt

In the command prompt, type the command below and press enter.

DEL /F /S /Q /A "Full Path of Folder*"

File should be deleted now.

Close the command prompt.

NOTE: If you used a command prompt at boot, then also close the System Recovery Options window and restart the computer.

For more information you can check out this Sevenforum article.

  • 1
    With the first method: i.imgur.com/OLUQs.png. As for the second method, I don't want to delete my desktop. – Jon Oct 5 '12 at 0:12
  • Did you tried the command prompt in safe mode? Also try the command prompt at the boot time and try to delete the file. I have given the link in my answer that how to open command prompt at boot time for that you just need a Windows 7 repair/installation disc. – avirk Oct 5 '12 at 1:31
  • Also have you tried bootdelete to delete the file? – avirk Oct 5 '12 at 4:14
  • 1
    Yes. Still didn't work. – Jon Oct 5 '12 at 22:37
  • 1
    Command prompt crashed or you talking about the bootdelete? If none is working then linux live cd will help you, which you don't need to install just put it the drive and play it and it will let you delete this stuff. – avirk Oct 6 '12 at 2:07

Take ownership of the ISO file and then delete it. This happens sometimes on my Win7 x64 as well.

You may also want to consider adding this option in the right-click menu so you can take ownership of any NEW file before you start working with it.

On a side note, Unlocker now has a 64-bit version too.. :)

  • 2
    +1 for mentioning 64-bit version, most of the user's install the 32-bit version and puzzled on 64-bit Windows. – avirk Sep 26 '12 at 0:52
  • 1
    I'm already the owner of the file and I can't delete it. – Jon Sep 30 '12 at 1:07
  • @chipperyman573, you may be the owner, but you also need permissions (permission s, not permission). Use the security tab to add write/delete permissions for your user account to the file’s ACL (access control list). – Synetech Sep 30 '12 at 1:15
  • 1
    I have all of them – Jon Sep 30 '12 at 1:20
  • You need permissions for Windows8-ReleasePreview-UpgradeAssistant.exe, the ISO file is locked because it’s open (two different casues of locked files). – Synetech Sep 30 '12 at 3:59

Windows includes the ability to mark files for deletion upon reboot. This ensures the files are not in use at the time as they are deleted by the system before Windows starts completely.

An application such as this one exposes this functionality to the end user.

Edit: I would recommend MoveFile as it is from a reputable source (Thanks Ansgar).

  • Another option would be Sysinternals' MoveFiles. – Ansgar Wiechers Sep 4 '12 at 9:29
  • Of course, I had forgotten about this one. – Luke Sep 4 '12 at 22:44
  • I wouldn’t recommend deleting the file like that willy-nilly. If something is using it, then by deleting it, you may break something (that could end up crashing the whole system). It is better to find out where/what is locking it and stop that. – Synetech Sep 30 '12 at 1:16

It is possible that win8install.iso is mounted as a virtual drive in Windows.
Since Windows 8, any .iso can be mounted natively without the need for third-party software.

You can find a description of the process in How to Mount or Unmount ISO images in Windows 8.

You can verify whether this is the case by calling Windows Explorer :


  • I've already tried this. Plus, win8 is installed on a virtual machine (I never actually installed the one in my drive), which is now deleted. – Jon Oct 2 '12 at 13:39
  • Well, if this VM is now dead, then no more problems. – harrymc Oct 2 '12 at 16:38
  • Except for the stuck icon. – Jon Oct 2 '12 at 19:03
  • 1
    OK, I misunderstood. You might add to your post what you see when you right-click the icon and select Properties. – harrymc Oct 2 '12 at 19:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.