1

I have used a PPA for more recent versions of digiKam (and supporting libs). I now want to install 'standard' Wine but getthe results below. Note that I tried to install Wine first but tracing through error messages got me to this. Also note that I am running 64-bit Kubuntu 12.04 (Precise Pangolin) and even when I try to install the AMD64 Wine I still get led back to this :i386 package issue.

altendky@ly:~$ sudo apt-get install wine1.4-i386
[sudo] password for altendky: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine1.4-i386:i386 : Depends: libgphoto2-2:i386 (>= 2.4.10.1) but it is not going to be installed
                     Depends: libgphoto2-port0:i386 (>= 2.4.10.1) but it is not going to be installed
                     Recommends: gettext:i386 but it is not going to be installed
                     Recommends: libsane:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
altendky@ly:~$ apt-cache policy libgphoto2-2
libgphoto2-2:
  Installed: 2.4.14-precise~ppa1
  Candidate: 2.4.14-precise~ppa1
  Version table:
 *** 2.4.14-precise~ppa1 0
        400 http://ppa.launchpad.net/philip5/extra/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status
     2.4.13-1ubuntu1.2 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
     2.4.13-1ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

So it would seem that I have a satisfactory package installed but apt-get is not detecting that 2.4.14 is >= 2.4.10.1. Other than generating my own equiv package or modifying the Wine package to change dependencies... can I help apt-get understand this?

Of course, the alternative is that apt-get understands perfectly and I'm the one that is confused.

0

Sometimes it helps to manually install the dependency first.

sudo apt-get install libgphoto2-2
sudo apt-get install wine1.4-i386

You probably have to remove the partially installed wine package first.

sudo apt-get remove wine1.4-i386

Sometimes you can force installation by running

sudo apt-get install --fix-broken
2
  • While this may answer the question, please try to expand your answer giving detailed steps and an explanation. Remember, this site does got lots of Google traffic for people asking the same question. We are here for users of all levels (including new users), with advice from computer professionals Sep 3 '12 at 22:09
  • Thanks for the effort, but it's a no-go. libgphoto2-2 already newest, wine1.4-i386 not installed... tried a couple permutations.
    – altendky
    Sep 4 '12 at 1:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.