I am running Windows 7 32-bit on an old laptop with an onboard parallel port. I have an Okidata Microline 320 printer connected to that port; the printer has been tested to work fine when printing from a Winterm in emulation mode.

The ML320 driver that ships with W7 is outputting garbage when I attempt to print (I have tried from Notepad and from Word 2010). In an effort to troubleshoot this, I tried running various commands from cmd, such as echo hello > lpt1 and echo.>lpt1, neither of which did anything.

If I type simply lpt1, the "choose a program to open this file" dialog comes up, but telling it to open with Notepad does nothing. print lpt1 returns the expected Can't find file lpt1 to stdout.

Any ideas as to why this isn't working?


Restarting the printer seems to have corrected this. I feel silly now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.