I have an USB drive with about 8GB of size. It has a single partition of size 169MB. Don't know why, I got it that way. I wanted to delete this small (FAT32) partition and create a single NTFS volume on it.

First, I noticed that the "Delete volumme" option is disabled (grayed out). I then tried "Change drive letter and paths..." and removed "F:", that way I made sure that there are no open files on it. The "Delete volume" was still disabled.

Then I got suspicious, and right clicked on the "Unallocated" area and I noticed that I did not have any useful option. All "New * volume" items are disabled.

I exited from diskmgmt.msc, ran a cmd.exe with administrator privileges, ran the diskmgmt.msc from it, same experiences.

Why can't i do anything with this disk? I've read some advices about downloading some alternative free software, but I rather not do it if possible. I still hope that Windows 7 Enterprise 64bit alone can reinitialize an USB drive without external help.

I also cannot do anything with my other 8GB pendrive. It's all an NTFS volume, I tried to delete it, but the option is disabled here too. Maybe I have some settings somewhere that prevents my from partitioning USB disks. (I have the freedom to remove my D: partition which is the second - not counding the "System reserved" - on my SSD disk.)

  • That worked. You may add a regular answer instead of a comment :-) – Notinlist Sep 4 '12 at 10:42
  • Glad it worked. – ta.speot.is Sep 4 '12 at 11:09

You can try diskpart or a low level format, assuming it's safe to do so on your USB drive.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.