I am having this unusual issue with my system. It started with not being able to install the Microsoft Skydrive app and has snowballed.

I am running win7 professional 64 bit.
Adobe flash player is installed in the 64bit IE9 and works fine, as well as JavaScript and general browsing (This is not my main browser). Chrome, and FF work fine as well, however if I use the 32bit IE9 I am not able to run any JavaScript what so ever and adobe flash player states it is not installed even though I believe it is with the latest version of 11.4 integrating both 32bit and 64bit.

So how have I come to the belief that it is JavaScript? Well I noticed a few other simpler pages not work correctly so I guessed a few times and went to w3schools to test a simple JavaScript applet and it did not work. I have gone to internet explorer --> Tools--> security and ensured that active scripting is enabled everywhere I can.

Things I have tried, uninstall - reinstall flash player and no matter what I do no dice. I've also tried an IE9 reset through the Microsoft site no dice. All my settings seem to be correct where do I go from here? I have reverted to previous versions of flash, and the new one.

  • Switch to chrome and never look back. – rlemon Sep 4 '12 at 12:56
  • 1
    @rlemon - While this can often be a solution it sometimes is not possible. – Ramhound Sep 4 '12 at 13:06
  • Do you use Asus Xonar ? – Dave Sep 4 '12 at 13:07
  • 1
    @Justin - You do understand that Java and JavaScript are entirely two different thing right? They have nothing to do with one another. What version of Java do you have installed? – Ramhound Sep 4 '12 at 13:08
  • Have you tried disabling (uninstalling) IE from 'Add/Remove Windows components' and re-enabling it? @Ramhound it is only ever 'not possible' because some sys admin decided so. I would suggest talking to said admin so they can correct the issue or allow you to install a real browser. – rlemon Sep 4 '12 at 13:09

Please try

  • Open the control panel
  • internet options
  • advanced tab
  • then click reset button.
| improve this answer | |
  • reset is always there to rescue. :) – Ankit Sep 4 '12 at 13:39
  • Tried and it makes absolutely no difference. – Grubbypandas Sep 5 '12 at 2:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.