I have Thunderbird 15. I'd like to automatically move messages from one folder to another.

My mail account is an IMAP account. My Blackberry is also connected to the account and when it sends mail, it places a copy on the IMAP server in a folder named Sent Items. I'd like those messages to be moved to my Inbox automatically.

By default message filters are only applied automatically to the Inbox. There is an extension to do this, Filter Subfolders, but it's only for TB3.

What I have tried so far is:

But I can't get these filters to run automatically. I have a suspicion that filters only run automatically for incoming mail. And these are sent items. Perhaps that's it. I just don't know. On the other hand, if I run the filters manually on that folder, it does indeed move the mail.

Or perhaps the issue is that these messages are saved into the Sent Items folder marked as read. Is it possible that filters are only automatically applied to unread items?

If I could install an add-in that automatically ran the message filter on my folder, that would do it.

Anyway, I'm at a loss now. Any suggestions are welcome. I'm not at all wedded to using filters. I just want to find a way to get these messages moved without human interaction!

  • I still haven't been able to find a good solution for this. Mar 27, 2013 at 17:43

3 Answers 3


You can use message filters tool of ThunderBird.

  1. Go to Tools -> Message Filters
  2. Add New Filter. Select a name, a type of match and the perform action (destination folder).
  3. Select the source where the filter will run.
  4. Run now.

You could create the filters that you need.


  • 1
    Welcome to SuperUser! Can you edit your answer to include the relevant information here please? :)
    – bertieb
    Mar 29, 2017 at 15:55
  • This is the best answer.
    – xpda
    Dec 6, 2020 at 3:45

Message Filters Button add-on will ease the problem. It is similar to the "Run filters on Subfolder" add-on.

This issue bothers a lot of people: Bugzilla thread regarding this bug.


I found solution see reply of geoyo1 at forum, works for my Thunderbird 17.

create a new string preference "mail.server.default.applyIncomingFilters" to "true". Even if it seems odd, do NOT create a boolean setting, it has to be a STRING setting with the value "true".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .