When I try to boot from my flash drive, my GIGABYTE 970A-UD3 motherboard returns this:

Loading Operating System ...
Boot error

All other motherboards I've tried support booting from that flash drive (and a backup flash drive). The operating systems I tried on both flash drives were created with usb-creator-gtk (Ubuntu USB Startup Disk Creator).

I know that the motherboard understands that there is an operating system on the flash drives because when I erase them, it complains in an ALL CAPS RAGE that there isn't an operating system, which is correct.

How can I boot a flash drive that's bootable from other motherboards on this motherboard?


  • This question is not a duplicate of this one because directly writing to the flash drive as an ISO 9660 (dd if=operating_system.iso of=/dev/sdb) still does not have the motherboard recognize the operating system.
  • This question should be a duplicate of this one because I provide more information not provided by that poster.
  • This forum thread has broken links and does not have a solution to my problem.
  • Nobody knows what's going on in this forum thread.

Use Plop Boot Manager.


2  computers
    1  computer with the problematic (GIGABYTE) motherboard
    1  computer for write operations to flash drives
    1  (tiny capacity) flash drive for Plop Boot Manager
    1  (larger) flash drive for the anticipated boot disk
1  open USB slot


  1. Download Plop Boot Manager. Get plpbt-x.x.x.zip (where x.x.x is the latest version number).
  2. Extract the .zip file you downloaded.
  3. In the folder resulting from the extraction, find plpbt.img.
  4. Unmount your tiny FDD.

  5. Write the file (Plop Boot Manager) to the beginning of your tiny FDD with this:

    Linux: sudo dd if=plpbt.img of=/dev/sdn

    Mac: sudo dd if=plpbt.img of=/dev/diskn

    (Assumes that you changed directories (cd plpbt-*) into the extracted folder. Replace the value of the of= parameter with the path of your particular flash drive. Be careful with this command by checking it for correctness!)

    Windows: Use Win32 Image Writer to write the .img file.

  6. If you haven't already, write the bootable operating system to your other flash drive like normal.


  1. Plug the Plop Boot Manager FDD into the computer with the problematic (GIGABYTE) motherboard.

    [Screenshot of inserting a flash drive]

  2. Reboot or power on that computer. On GIGABYTE motherboards, press F12 at the BIOS splash.

    [Screenshot of a GIGABYTE motherboard boot splash]

  3. Select the Plop Boot Manager FDD for booting. On GIGABYTE motherboards, choose either USB-ZIP or USB-HDD. The flash drive is actually recognized as a floppy, not a regular flash drive.

    [Screenshot of a GIGABYTE motherboard boot selection menu]

  4. Plop Boot Manager should now be running. There may be a starfield screensaver in the background.
  5. Plug in the other FDD. (Exchange with the Plop Boot Manager FDD if you're out of slots.)
  6. Select the flash drive option from the Plop Boot Manager menu.

    [Screenshot of Plop Boot Manager boot menu]

Now the bootable flash drive operating system should be starting up!

As a bonus, there are other uses for your Plop Boot Manager FDD now, and it can be your "key" to other possible booting issues you might encounter.

  • how tiny is "tiny FDD"? will a 512 megabyte capacity one do? – sterz Dec 18 '12 at 18:56
  • @sterz: Yes, any flash drive larger than 1.44 MB will suffice. – Deltik Dec 18 '12 at 19:58
  1. In the BIOS, ensure you have Integrated Peripherals > USB Legacy Enabled.
  2. Also ensure you have Integrated Peripherals > USB Storage Enabled.
  3. Set Boot Order to HDD, None, None.
  4. With the USB Boot Drive inserted, Reboot.
  5. Hit F12 at the Boot Screen to bring up the Boot Menu.
  6. Choose HDD+ on the Boot Screen, not any of the USB options!
  7. Choose your USB Device on the next screen.

Source: http://forums.tweaktown.com/gigabyte/24883-welcome-gigabyte-technical-support-133.html#post394471

HOURS of research - I hope this helps.

  • As an additional note to Ryan Shirpat's answer above: You must use a USB 2 port, My flash drive (a Corsair Voyager, USB3) didn't show up or boot until I plugged it into a USB 2 port. – WillNewby Apr 10 '17 at 5:13
  • This worked for my GA-G41M-ES2L, but the "HDD+" option was listed as "+ Hard Drive" in the Boot Menu. – Chris Betti Nov 5 '17 at 16:54

I encountered the exact same problem but was unable to get plop bootloader to work. I think Startup Disk Creator in Ubuntu wasn't doing a good job.

I fixed the problem by using dd if=iso of=usb on os x. It took a long time to copy the iso, but it did finally boot.

I also had to boot from +HDD (not USB-HDD). Prior to making the iso on mac, the USB:HDD0 option would not appear in the +HDD menu, though.

  • Hey jroz, can you post your answer with more details? When you say you used dd if=iso of=usb, did you really use the iso or is it a typo for the img file? Because in most tutorials I've seen, they use the img. – agarie Jul 8 '14 at 17:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.