i have a Acer Aspire One D257. In this netbook the hard disk is defect so i bought a new one. Now i want to reinstall Windows 7. Im using an external DVD Drive plugged into USB.

The Windows 7 DVD is staring, Win7 setup is starting and when it comes to Hard Drive options it says that no drive was detected and i should try search for drivers. It shows me this window: Screenshot from web

Now i cant find the right drivers for this netbook to continue with the installation.

The laptop has the newest BIOS - 1.15, it is reset to factory default settings except that i enabled the Boot Menu prompt with F12.

From the Acer Support Website i've downloaded the SATA AHCI Driver and the Chipset Driver. I unpacked both to a USB flashdrive in seperate folders.

When i select the SATA AHCI Driver it does not find any drivers. When i uncheck the checkbox "Hide drivers that are not compatible with hardware on this computer" it shows one driver: Acer HWID (path_to\1.inf). When i continue with this driver i got an error message that says something like: No new devices found. Check if the driver files are on the installation disk.

When i show him the Chipset Driver it sees a lot more driver. When i uncheck the checkbox "Hide drivers that are not compatible with hardware on this computer" it show some drivers:

Intel N10 Family DMI Bridge
Intel N10/ICH7 Family PCI Express Root Port
Intel N10/ICH7 SMBUS Controller
Intel N10/ICH7 Family USB Universal Host Controller
Intel N10/ICH7 Family USB2 Enhanced Host Controller
Intel N10/ICH7 Family Interface LPC Controller

When i uncheck this checkbox i get a lot more drivers, and some SATA Drivers but the also do not work. I get the same error message as before.

Can someone help me find a driver that should work or am i doing anything else wrong?

  • Does the BIOS of the netbook detect the harddisk? If not then it is not a driver issue. – Hennes Sep 5 '12 at 16:38
  • Yes, it sees the HDD. No problem here. – Robert Niestroj Sep 5 '12 at 17:48
  • I installed Ubuntu 12.04.1 LTS on this netbook and it works so hardware seems to be ok. This must be w Windows 7 or driver issue. But i still cant resolve it. – Robert Niestroj Sep 7 '12 at 15:10

Windows 7 doesn't support installation via USB 3.0 port. You have to install it from USB 2.0 or less

  • Can you clarify why this is the proper answer to this question? Please add a source which backs up what you are saying. – CharlieRB Mar 31 '15 at 15:53
  • @CharlieRB Windows 7 doesn't have a generic USB3 driver like Windows 8, so you have to add the USB3 driver to the boot.wim or use USB2. So Claude is correct. – magicandre1981 May 1 '15 at 8:30
  • @magicandre1981 I didn't say the answer was wrong. I asked for context and a source to back up the short answer. – CharlieRB May 1 '15 at 11:56
  • @CharlieRB: The answer is wrong. The laptop doesn't have USB 3 and even if it did, the problem is nothing to do with USB. It's a missing SATA driver. – qasdfdsaq Aug 5 '15 at 10:41
  • 1
    @qasdfdsaq Why are you addressing me? I did not give this answer. For the sake of improving the answer (or not), I commented to ask the person who posted the answer to clarify why it is proper and back it up with a source. – CharlieRB Aug 5 '15 at 12:51

Not sure if anyone is still having this issue, but I just ran across the same problem. Here's my simple fix in case anyone else can benefit from it.

Step 1: Enter BIOS settings and make sure the SATA drive type is set to AHCI, not IDE.

Step 2: Install Windows.

If this worked for you, you're welcome.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.