1

I've tried both Nouveau and the NVIDIA Binary Blob, and both are terrible in terms of performance, lag and graphics corruption. The binary also doesn't support the native resolution in console mode and requires you to use nvidia-xsettings to change anything. Both have been blacklisted for Ubuntu Unity shell as far as I can tell. What am I to do with the graphics drivers on this PC?

2
  • I think this LINK is useful for you. – Mohammadhassan Esfahanian Sep 5 '12 at 15:37
  • Are you using the NVIDIA binary drivers packaged with Ubuntu, or the installer from NVIDIA? – Jacob Hume Sep 5 '12 at 15:46
0

Your best option would be to search for ubuntu recommended nvidia drivers via synaptic package manager. Look for synaptic package manager in your install and if it doesn't exist you need to install it using sudo apt-get install synaptic via terminal. I think nvidia-glx will be the right one for you. Open synaptic manager and search,install both nvidia-glx and nvidia-xconfig. After that run sudo nvidia-xconfig using terminal and go for a reboot. And make sure you blacklist the other ones.

4
  • I should add, there is a package called nvidia-detect available via synaptic. Install it, and run sudo nvidia-detect in terminal before you follow what i said above. It will suggest the right driver for you. It should be nvidia-glx. – paintbox Sep 5 '12 at 16:46
  • nvidia-detect doesn't seem to exist in the repos, and nvidia-detector returns none – Adam M-W Sep 6 '12 at 15:03
  • Have you gone to additional drivers section to look for a suggested driver? Also take a look at this thread. It suggests a working driver. ubuntuforums.org/showthread.php?t=1771806 – paintbox Sep 7 '12 at 12:03
  • You should also try your luck with nvidia-glx. Assuming you know how to get back if it goes blank, try installing it via command line. sudo apt-get install nvidia-glx nvidia-xconfig and run sudo nvidia-xconfig. reboot. – paintbox Sep 7 '12 at 12:08
0

Well. Working with Ubuntu at work, but it is headless. At home I choose to comile every grain myself with Gentoo. Just came back from nouveau to nvidia legacy driver, due to the lack of speed. For official driver, you have to grab a legacy driver. Official legacy driver for Nvidia 7400 Go currently is version 304.x. It's still being updated so won't say 304.137 which is version I use, but get a 304 with a high revision to avoid problems (http://www.nvidia.com/object/unix.html). Also keep you bios updated (Just see if it is). On Gentoo I also have to disable/enable the right accelerarion. VDPAU is only supported on PureVideo able cards (Available on most or all Series 8 and beyond). VAAPI should be avaiailable for the 7400. There are wiki on these, so I'll avoid explainations what it stands for. I have a Nvidia G72M/Nvidia 7400 Go GPU [use lspci command to see yours] on my old laptop, which is what I base most of the info from.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.