There are two active user accounts on the Windows 7 Professional server, Owner, and Guest.

  • Owner is an Administrator with a password.
  • Guest is the default Guest account with no password, but has been added to Remote Desktop Users.

When attempting to connect to the server via a Windows 7 Professional client, Guest accepts RD connections fine, however, Owner throws an error "Unable to connect to Local Security Authority."

I created a new Administrator account, named Remote, with the same password as Owner. Remote Desktop worked perfectly. I then deleted Owner, and renamed Remote to Owner.

Now, Remote Desktop gives the same error ("Unable to connect to Local Security Authority") when attempting to log into the new Owner. However, attempting to log into Remote (even though it was renamed to Owner), works.

Completely at a loss here, what is going on? Why won't Owner work, and why does Remote Desktop still use the old name on the renamed account?


Do not rename the user account. Create the user "Owner" directly.

Renaming a user causes problems. If you look in the folder c:/users/ you will still see the old user name instead of the new username.

When you rename a user account in on a computer that is running Windows Vista, Windows Server 2008, Windows 7 or Windows Server 2008 R2, the user profile path is not changed automatically. It may cause some confusion when the %SystemDrive%\users folder is viewed

Renaming a User Account Does Not Automatically Change the Profile Path

There is a fix in the link above, but it's always better to create than rename user accounts...

  • I had the same rdp problem you had, and it was solved by deleting the old renamed account and creating a new clean account. I can not be sure the cause, but maybe someone here can add to the discussion. – Logman Sep 6 '12 at 0:13
  • try the reg fix from the link, probably only way to rule it out – Logman Sep 6 '12 at 2:44
  • This is the typical *rap Microsoft has us dealing for years. Make it work first. This has been around from the days of XP. By now it's not a bug it's a feature. – unom Feb 3 '15 at 11:30

There is one step missing from that Microsoft page I want to share with everyone since it did not work until I did this final step.

From the Microsoft page:

  1. Log in by using another administrative account. Note You may need create a new administrative account at first.
  2. Go to the C:\users\ folder and rename the sub folder with the original user name to the new user name.
  3. Go to registry and modify the registry value ProfileImagePath to the new path name. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\\

My added step:

  1. Go to computer management, local computers and users, open the users folder and RENAME the old user account to the new one. log off and back on as the new user.

Once all these steps are complete you should be able to RDP with the new user information. Hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy