I am getting the following message when attempting to connect to our company's SVN repository - the same error occurs whether I try from the OSX command line or Eclipse.

Any ideas on where to troubleshoot?

I can access from other similar computers and others in my team do not have any problem - this issue started occurring on my MacBook Pro yesterday afternoon (no known changes were made to the OS prior to problem starting).

$ svn co http://example.ca/cwl/tags/app
svn: OPTIONS of 'http://example.ca/cwl/tags/app': Could not read status line: connection was closed by server (http://example.ca)*

3 Answers 3


I'm experiencing the same problem on MBP running 10.7.5. Some other guys are reporting a similar problem at https://discussions.apple.com/thread/4280660 and SVN Error when connecting from MacBook

The svn+ssh connection and https connections work all ok. My other machine, running the same OS version does not have the problem.

An interesting thing is that I tried to run svn on a Ubuntu inside a virtualbox. It is experiencing the same results: svn ls http:// does not work; svn ls https:// works

Do you use Cisco AnyConnect 3.1 VPN? A note at https://stackoverflow.com/questions/12808500/svn-could-not-read-status-line-error -on-checkout suggests that the culprit could be the Cisco VPN client. I've recently upgraded to Cisco AnyConnect 3.1, and at about the same time svn ls http:// stopped working.


After some research I did the following and it solved my problem and helped me unblock the issue. The web security module is causing this issue. So I had to uninstall it.

  1. Open up the terminal and go to cd /opt/cisco/anyconnect/bin.
  2. Inside bin folder there is an uninstall script for web security module, websecurity_uninstall.sh
  3. sudo ./websecurity_uninstall.sh

That’s it. My SVN is back working again, and right now all the things work fine.


We had the same issue in combination with Cisco AnyConnect 3.1. For us the problem seems to be the Web security plugin of AnyConnect. After uninstallation of AnyConnect (sudo /opt/cisco/..../bin/vpn_uninstall.sh + any other uninstall.sh script) we reinstalled AnyConnect just with the option "VPN" selected. Afterwards it worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .