2

On one of the machines that I have Ubuntu installed NetworkManager has to be started manually by me (sudo NetworkManager start - as far as I remember). It is a bit inconvenient to be forced to start NetworkManager every time by hand. I think it started working like that after I bought myself a wireless router and stopped using direct PPPoE connection.

On all other machines it works as expected.

3

OK. I've managed to fix the issue. I've tried to compare as many configuration files related to networking as possible.

  1. A change in NetworkManager: I had to change managed (in ifupdown section) to false. That didn't fix the issue itself, but may be connected.
  2. Having a look at http://wiki.debian.org/NetworkManager I've changed my /etc/network/interfaces to be exactly as the one on my second machine (which works without any problems). My interfaces file was:


auto lo
iface lo inet loopback

allow-hotplug eth0
auto eth0
iface eth0 inet dhcp

and I've changed it to:


auto lo
iface lo inet loopback

And now it works! I hope it will help others having similar issue (especially when dealing with PPPoE in the past).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.