I'm using Cisco Client VPN. When my laptop (Windows 7 Enterprise) sleeps or hibernates I can still connect (or least the client tells me the VPN connection was successful). However, I cannot ping or connect to VPN'd resources. I have tried killing virus protection (McAfee), but that didn't help.

Does anybody have any insight and a solution to this problem?


Unfortunately, there's no real true "fix" for this problem. It's documented as an issue as Cisco defect ID CSCsf96588. A check of Cisco's release notes (page 5) for VPN client 5.0.06 and .07 both mention it as an issue.

They've issued a software fix to change the way the client re-establishes a secure tunnel, but it's still a problem for platforms.

Cisco's workaround is a recommendation to shut down the VPN client before going into sleep/hibernation mode.

| improve this answer | |

A way to resolve this issue is to turn off VPN connection via Task Manager before the system goes to hibernate. Find below the scripts that I use to turn off and disconnect VPN before hibernation and then to turn it on after the computer comes back up from sleep.

Before Hibernate:

    REM Before Hibernate
    REM Begin the Task: On an event
    REM Setting Basic
    REM Log:  System
    REM Source: Kernel-Power
    REM Event ID: 42
    REM The system is entering sleep.

    "c:\Program Files (x86)\Cisco Systems\VPN Client"\vpnclient.exe disconnect
    taskkill /f /fi "imagename eq vpngui.exe"

After Hibernate:

    REM After Hibernate

    REM Begin the Task: On an event
    REM Setting Basic
    REM Log:  System
    REM Source: Power-Troubleshooter
    REM Event ID: 1
    REM The system has resumed from sleep.

    cd "c:\Program Files (x86)\Cisco Systems\VPN Client"
    start vpngui.exe

reference: How to execute a script on sleep, hibernate, resume, and shutdown

UPDATE1: Another way that I was able to resolve it is to disconnect from current WiFi and connect to a another one. It also fixed problem few times.

| improve this answer | |

Restarting network-manager worked for me:

sudo /etc/init.d/network-manager restart
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.