I'm suffering a strange problem with my Cannon iP4850 when trying to use CUPS on a Raspberry Pi (this is not RPi specific, please do not vote to move it).

When I plug the printer into my Laptop (OSX) or my Desktop W7 it identifies as a iP4800 and prints perfectly.

So I plug it into the Pi (running debian), set it up in CUPS enable sharing and can now see the iP4800 series shared on the network.

However if I print to it (using AirPrint etc...); the file gets to CUPS safely (shows in the queue) but when it tries to print the printer clicks (like a loud thunk) 3/4 times and then gives in, with a double amber flashing light. In cups it shows as job completed.

Do you know why using the pi and cups would cause what appears to be a hardware fault and what I can do to fix the problem or to provide further debug info?

Thanks for your time!

Description:    Canon iP4800 series
Location:   Lounge
Driver: Canon PIXMA iP4800 - CUPS+Gutenprint v5.2.9 (color, 2-sided printing)
Connection: usb://Canon/iP4800%20series?serial=2239B2

Note: I've tried deleting and re-adding the printer to the Laptop, Desktop and PI and the results are always the same

Log for plugging in printer and printing (attempting to) something until the printer turned off again

pi@pezpi /var/log $ dmesg
[ 7284.176336] usb 1-1.2: new high speed USB device number 8 using dwc_otg
[ 7284.279703] usb 1-1.2: New USB device found, idVendor=04a9, idProduct=10d5
[ 7284.279750] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 7284.279771] usb 1-1.2: Product: iP4800 series
[ 7284.279786] usb 1-1.2: Manufacturer: Canon
[ 7284.279800] usb 1-1.2: SerialNumber: 2239B2

Setting cups to verbose:

Change loglevel in cupsd.conf to debug (or debug2)

pi@pezpi /var/log $ sudo vim /etc/cups/cupsd.conf
pi@pezpi /var/log $ sudo /etc/init.d/cups restart
[ ok ] Restarting Common Unix Printing System: cupsd.
pi@pezpi /var/log $ 

Log from $ /var/log/cups/error_log is at http://pastebin.com/7VZMRMrG (too large to post here)

The log contains - in order (deleted the log and then did the beneath)

  • Restarting the cups server
  • Attempting to print a test page x2
  • Printing from via AirPrint
  • Printing from via Network Print
  • Turning the printer off and on again
  • Check system log (dmesg) and CUPS log(?). Look for a way to make CUPS verbose. – sawdust Sep 8 '12 at 20:02
  • Have uploaded a full copy of the log – Pez Cuckow Sep 8 '12 at 21:04
  • Line #15 of the CUPS error log looks ominous. Did you install anykind of CUPS driver or cupswrapper file for this Canon printer? Or is it installed as a "raw" print device? – sawdust Sep 8 '12 at 21:47
  • Maybe you need to install a driver like this? software.canon-europe.com/software/0040246.asp?model= – sawdust Sep 8 '12 at 22:08
  • I installed the PPD file (compiled from source) taken from the Cannon website for the iP4850 so I'm not sure it's the drivers. As far as I'm aware I haven't installed any CUPS specific driver (taken from software.canon-europe.com/products/0010893.asp) – Pez Cuckow Sep 8 '12 at 22:30

Just replying as I had a very similar problem with my Canon PIXMA iP4300 printer: CUPS reported that jobs were being printer whereas they weren't. In the end, the solution I stumbled across was to go to 'Set Default Printer Options' in CUPS and change the colour model to CMYK (it was set to RGB as default). This solved it! Maybe it works for you too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.