VLC player is not showing subtitles correctly. It's just showing capital "A"s in place of the correct text. Please check the screenshot attached to this post.

Do I need to install a missing font? How can I fix it?

Can I export .srt file from the subs embeded into this mkv file?

enter image description here


I have had that happen with several different .ass subtitles. For example subtitles with the Plain with border style were not displayed correctly in these subtitles:

[V4+ Styles]

Format: Name, Fontname, Fontsize, PrimaryColour, SecondaryColour, OutlineColour, BackColour, Bold, Italic, Underline, StrikeOut, ScaleX, ScaleY, Spacing, Angle, BorderStyle, Outline, Shadow, Alignment, MarginL, MarginR, MarginV, Encoding
Style: Default,Trebuchet MS,40,&H00E6F4FC,&H000000FF,&H00000000,&H00000000,-1,0,0,0,100,100,0,0,1,1,1,2,10,10,10,1
Style: Plain with border,Arial,30,&H00000000,&H000000FF,&H00FFFFFF,&H00000000,0,0,0,0,100,100,0,0,1,2,0,5,10,10,10,1    

It was fixed by changing the bold attribute from 0 to -1 or just deleting the styles completely. MPlayerX has also displayed those subtitles correctly.

You can extract subtitles from mkv files with mkvextract:

brew install mkvtoolnix
mkvextract tracks video.mkv -c UTF-8 3:subs.srt

Another common issue is that VLC shows characters that are not included in the default subtitle font as rectangles. It can be fixed by just changing the default font. You can also change the text rendering module to CoreText font renderer, but it makes text look too thin in my opinion.


Try changing the subtitle encoding. I don't have access to vlc at the moment but it there is an option in the preferences to set the encoding. I would first try UTF8.

You may also need a font that can display your language.

  • +1 yes you need a font that can display your language
    – jsj
    Sep 10 '12 at 13:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.