Ok let me try this again, so sorry for not be clear. We create our PDFs through Quark, then send to print. I usually create outlines on my EPS files before I load in Quark but forgot this time. We bypassed the font error that Quark gave us by accident and found out our PDF was bad too late and it cost a lot of money to fix.

We are trying to find a way to check our PDF for font problems before we send it to print, in case this problem happens again. We just want to be extra sure that we have tried everything.

What I see in Quark is what the font is supposed to look like. When I view my PDF, the text is mixed up. Its readable but doesn't look like its supposed to and the spacing is all off within the text.

My boss told me about the preflight in Quark and the Internal Structure for the fonts. She was asking me if this would help and what the lingo all meant. (which is where my first question started)

The image on the left is my EPS that is correct, the image on the right is from the PDF. The white text in the top right and the website at the bottom left is what is messed up. enter image description here

I am running Mac 10.5.8, Quark 7.5 and Acrobat 8.3.1.

Thanks, Jayme

  • We create the pdf in Quark. We are not familiar with all the codes and stuff, we are just searching for a way to find if a font is corrupt within Acrobat. Is this possible and easy for someone like me. LOL – Jayme Sep 10 '12 at 18:40
  • There are several PDF font issues described at files.quark.com/download/documentation/QuarkXPress/9/English/… – RedGrittyBrick Sep 10 '12 at 18:45
  • Can you provide a screenshot sample of what the text looks like when it's correct and what it looks like when it's incorrect? I understand it's a spacing issue, but the exact symptoms are important for diagnosing the problem. – allquixotic Sep 10 '12 at 19:24
  • I just tried to add a pic but it won't let me since I am a new user. :( – Jayme Sep 10 '12 at 19:34
  • Posting the link is enough, but you should have the reputation now! – slhck Sep 11 '12 at 6:48


Other than the human eyeball, I know of no tool that can inspect a PDF and infer that the program used to produce the PDF has substituted a font.

You could just assume that if Courier font is present in the PDF, something went wrong. A rough and ready check would be

strings filename.pdf | grep Courier

In general, to prevent this sort of problem, I would

0) Make sure any source EPS objects had all fonts embedded.

This is important if the Mac used for the Quark project lacks any of those fonts.

I usually create outlines on my EPS files before I load in Quark but forgot this time.

Converting characters to outlines (i.e. to curves and control-point data) is another way of removing any requirement for the consumer/recipient of the EPS to itself have the used fonts already installed.

1) Make Quark embed fonts

Font Settings

When you export a layout in PDF format, you can choose to reference or embed (download) the fonts used in that layout.


  • Embedding means that the fonts themselves are included in the PDF file. This increases the size of the PDF file, but ensures that the file will display or output correctly.

2) View the list of fonts in Acrobat

and double check that it shows them all as being embedded (Menu: File -> Properties, Fonts tab)

Acrobat Reader fonts dialog

I'd worry about the 5th font in this list.


Jayme's zip file shows a Quark dialog box that says

"Some EPS/PDF pictures in this document use screen fonts not available in your system, including Univers-Condensed and Univers-CondensedBold"

It is clear from the final PDF image that Quark has substituted Courier for the missing fonts but has applied the letter-positioning from the EPS that would have been appropriate for Univers-Condensed.

One solution is to purchase and install Univers-Condensed and Univers-CondensedBold on the Mac where the Quark project is being output to PDF.

Another solution would be to go back to the application that produced the EPS that has been placed in this project and reproduce that EPS but force it to embed font (used subsets) into the EPS, then reimport that EPS into the final project before producing the final print-ready PDF.

  • Thank you so much for responding... in my pdf, all the fonts marked are showing (Embedded Subset) is that saying they are embedded or not? If its embedded why is my font still not right? – Jayme Sep 12 '12 at 1:30
  • @Jayme: It seems , at some point in your workflow, unwanted font substitution may have occurred. Would it be possible for you to post on a file-sharing site, either the PDF showing the problem or one you make up with some lorem-ipsum text (using the same quark fonts and workflow) that shows the same problem? – RedGrittyBrick Sep 12 '12 at 7:33
  • "Embedded subset" is normal, font foundries don't want copyrighted fonts embedded in their entirety, so programs just embed the subset of glyphs for characters that are actually present in the text. – RedGrittyBrick Sep 12 '12 at 7:37
  • Thank you so much @RedGrittyBrick. I have uploaded a zipped file to the link below. There is a pdf and also an error that I get in Quark when I save to pdf. I know this error would warn me before hand of the issue but sometimes my hand is to fast and I miss the error, which is what happened this go around. We just want to find out a way to be able to check our pdf files before they go to quark for any font issue in case this were to happen. dl.dropbox.com/u/23112357/FONTJayme.zip – Jayme Sep 13 '12 at 22:07
  • @Jayme: Quark couldn't find Univers-Condensed or Univers-Condensed bold on the Mac you used. It has substituted Courier. The letter spacing is obviously for a sans-serif proportional font like Univers with wide "w" and narrow "i" and "l". The spacing clearly isn't right for a serif monospaced font like Courier. I'd Purchase and install Univers-Condensed and Univers-CondensedBold on that Mac or go back to the source EPS and PDF that are embedded in the project and re-create them but this time embed the fonts. Presumably those elements of the project were produced on a different Mac. – RedGrittyBrick Sep 13 '12 at 22:39

You seem to be presupposing a particular solution in your question. Only in your second paragraph do you tell us what your question is. Your real question is "Sometimes when we send a PDF document to print, some of the characters/fonts don't print correctly. Why is this and how do we fix it?"

Trying to understand the internal structure of a PDF for a problem like this is somewhat of a fool's errand. I would recommend instead that you let the person answering the question propose a solution, rather than asking why the solution that you think should work is not working.

Anyway, some background information.

In every PDF, there are two types of fonts: embedded fonts, and referenced fonts.

Embedded fonts are contained in their entirety within the PDF itself. Any compatible PDF reader program should be able to print every character of an embedded font. If it can't, that's a separate problem. The advantage is that you can use custom fonts and the person viewing/printing the document will be able to read the fonts whether or not they have that font installed on their computer.

Referenced fonts are fonts that are only referred to "by name" within the PDF document, but the PDF relies on the operating system to have the font files present at the time of rendering/printing, or you get "font problems" like you said. The advantage is small file size.

The possible problems you could be having are many, and I can't tell which problem you are having from your question, so I'll enumerate them along with possible resolutions:

  • Your fonts could be embedded in the PDF, but your PDF printer/renderer could be having a problem parsing (using) the font(s). This is typically a bug specific to a piece of software, or perhaps it is incompatible with the font file format that is embedded. You can resolve this problem usually by upgrading your PDF printing software, and you should verify that the PDF renders correctly on a canonical PDF viewer such as Adobe Reader (the latest version) on Windows, prior to taking any corrective action.

  • Your fonts could be referenced in the PDF, but your PDF printer does not have that font available. You can resolve this problem by either (a) installing the appropriate font(s) on the computer/device that prints or renders the PDF, or (b) switching over your PDF creation software to embedding the fonts in the PDF rather than referencing them.

You can detect which fonts are referenced and which fonts are embedded by a number of ways (depending on your platform, etc) -- see this StackOverflow question. The first thing you can do is configure the software that generates the PDFs to always embed all fonts. This will increase file size; if you can deal with the resulting file size, it should make printing much more reliable.

You could also determine whether each referenced font is available on the system, but that is platform-dependent, meaning that the solution for doing so would depend on which operating system you're running and what kind of software environment is available to you e.g. for programming.

Overall this is a very vague question and I don't think it is particularly answerable in its current form because of all the possible variables that may be causing this problem. You seem to be asking about the internals of a PDF in a very abstract way without reference to any particular piece of software or platform. I have provided this answer in the attempt to be helpful, but please be aware that this question could be closed if it is not made more specific.

  • Oh my, I am so sorry... this is all new to me. My boss asked me to figure this out so I came here. Here is what happened... So, we create layouts in Quark and save as PDFs to send to our printer. I normally create outlines on all my EPS files that I place into quark, but this last go around I forgot one file. The font looked fine in Quark, but when we saved to PDF we saw it was corrupt... a little to late though. We are trying to figure out a way to view our PDF to find an error free way to find if a font problem exists. My boss told me about the preflight and internal structure. – Jayme Sep 10 '12 at 18:34
  • "Corrupt" is a misleading term. I don't think you are really seeing a font that is truly and precisely corrupt in the sense that there is valid data there that somehow got mangled. Seeing questionmarks or triangles or squares in place of the actual characters of the font is rather an indication that the font is missing. This would be a referenced font that is not present on the computer doing the printing. Is that what you're experiencing? There is no such thing as a general-purpose problem detector. You have to look for a specific problem by understanding, first, what the problem is – allquixotic Sep 10 '12 at 18:46
  • Please edit your question with as many details as possible about the software you're using, and the architecture of the computers used for creating the documents, how the documents are created, and how they are exported and then printed, including what operating system each step takes place on... you literally cannot provide too much information... – allquixotic Sep 10 '12 at 18:49
  • I really appreciate all your help and sorry I am not doing so well on my end. LOL Corrupt may be the wrong word... what I see in Quark is what the font is suppose to look like. When I view my PDF, the text is mixed up. Its readable but doesn't look like its supposed to and the spacing is all off within the text. – Jayme Sep 10 '12 at 18:57
  • Oh I am running Mac 10.5.8, Quark 7.5 and Acrobat 8.3.1. – Jayme Sep 10 '12 at 19:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.