I have a brand new DELL Inspiron which used to connect to my WiFI. I had the laptop off for about 2 months and when I turned it on it will not connect to my Wireless with WPA2+AES encryption. All of my other devices (iPad, Laptops, XBOX, Roku, etc) are able to connect without a problem. I also tried connecting to other opened WiFIs in my area and was unable to do so. I even tried connecting 2 feet away from the router without luck where the signal is excellent (so is everywhere else around the house).

Machine configuration:

  • Windows 7 64-bit
  • Adapter is Dell Wireless 1702 802.11b/g/n
  • Driver: Atheros Communications Inc, 4/21/2011, Version:

I tried:

  • Deleting the driver from Device Manager and restarting
  • Installing drivers from Dell, but it appears I have the latest version
  • Tried to connect to an unsecured Virtual Interface (DD-WRT)
  • Changed the Bandwidth on the adapter to 20MHz/40MHz Auto (my router is 40MHz channel width)

What could be causing the problem? What else can I try? What else can I provide to help troubleshoot this?



Your wifi is probably disabled on the machine.

First off, prove it by trying to connect with an Ethernet cable.

Lots of laptops have a light to show if wifi is on or not (near the keyboard)

Or, your typing the password in wrong. Make sure you have NumLock on. If you look carefully, the keys U,I,O,J,K and L have some numbers in the same color of the Fn key, i.e, 4, 5, 6, 1, 2 and 3. This is your numeric keypad. 3) Hold pressed both the left Alt key and the Fn key, while you write the code with the numeric keypad. Hope this helps.

  • 1
    I am able to connect with an ethernet cable. The WIFI is on because I can see the list of WIFIs – Jonas Stawski Sep 11 '12 at 14:32
  • Yes, I enter the correct password. It says "connecting" and then it comes up with the message: "Windows was unable to connect to [WIFIName]. Solve Problem." When I click on "Solve Problem" it opens up the "Windows Network Diagnostics Wizard", which doesn't solve the problem – Jonas Stawski Sep 11 '12 at 14:37
  • Can you open command prompt (type cmd in the search box) and type ipconfig and see if it says media disconnected or not? – Dave Sep 11 '12 at 14:38
  • 1
    Wow, I just plugged in an old G router and it connected without problem. It sounds like a compatibility issue – Jonas Stawski Sep 12 '12 at 14:01
  • 1
    for history sake I say we leave them as a way for people to find possible answers to their problems and add a new answer explaining what the issue was – Jonas Stawski Sep 12 '12 at 14:10

I was recently unable to connect an ipad to my home wifi. Everything else connected fine, but not this device.

Turned out the router LAN IP configuration had been set to allow a max number of 6 users. This device would have been the seventh, and so it wasn't allowed to connect. Once I increased this number, I no longer had any problems.

  • Interesting, could you edit your answer with the make and model of the router? – Burgi Apr 30 '16 at 12:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.