Currently I'm facing an issue when I'm trying to connect any USB flash drive to my PC.

  1. I can connect USB keyboard and mouse without any issue.
  2. However when I connect USB flash drive, there are 2 situations that are occuring randomly:

    • There is no USB drive mount in My Computer, when Device Manager is checked, it shows error code 10, but is shown in Disk Management.
    • My computer will have USB drive mounted, but when I click on it, it is empty. On right clicking the properties, the disk space shows 0. There are files on the USB.

What I have done is:

  1. Run CCleaner to repair the registry, restart and try, but still not working.

  2. Uninstall the drive in device manager, restart and try, but still not working.

  3. Tried the port that connects mouse and keyboard, but does not work.

Updated (2012-09-19)

1) the original usb drive work fine on other pc.

2) had perform microsoft fix it online, update chipset driver, but still cannot solve the issue.

3) when plug in sony usb to the same pc, it work fine

4) Found exclaimation mark indicate WPD File Systems Volumn Driver

  • Does the drive work on another PC? Also, have you tried the Hardware and Devices troubleshooter? – CharlieRB Sep 12 '12 at 11:49
  • Hi,the drive work fine on other pc. i had try your suggestion, i also try on the chipset update, microsoft fix it online but still the same problem. but when i try on sony brand of usb, it work fine, really have no clue. however, i found probably due to WPD File Systems Volume Driver, because there is exclamation mark.do you have any solution for this? – Tony Sep 19 '12 at 11:19
  • If the USB stick directly connected to the PC (e.g. on backside) or via extension cable or via USB-Hub? – Robert Sep 19 '12 at 13:36
  • Hi Robert, the USB connect directly to the pc – Tony Sep 20 '12 at 0:10
  • Did you try different host ports? – Mose Nov 2 '12 at 11:21

The fact other USB devices works on the afflicted PC and the fact the thumbdrive works elsewhere (but is elsewhere the same type of PC or even same operating system?).

Your next step, mount the USB drive on a Windows or Linux based system and perform a disk repair. In Windows it is typically:

chkdsk X: /f /x /r /v

(Replace X: with the actual drive letter.)

That will take some time depending on the size and speed of the USB drive. If the drive still fails to mount on your afflicted Windows system, consider reinstalling your usbstor.sys driver since it bridges USB storage devices for access.

You reinstall it by deleting usbstor.sys from C:\Windows\system32\drivers, then access its services (drivers are still listed as services in the Registry) location in the registry, compare the USBstor.sys registry layout to a working similar Windows system.

If that still fails, then consider reinstalling Windows because your problems are deeply embedded.


Here is what I did.

  1. Open start menu.
  2. Right Click on Computer and select Manage
  3. Select Disk Management on Left hand Column
  4. USB should show up on the list.
  5. Right click and select "change Drive letters and Paths"
  6. Select Add
  7. Select a Letter That is not already being used.
  8. Enjoy a working USB

P.S. When looked at in Device Manager it still shows up with Exclamation, but it works great so I figure it is a step forward.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.