Since I'm using Windows 7 (Beta, then RC, now RTM), I have issues when I download pictures from my digital cameras. It happens with my two cameras: a Canon Powershot S2 IS and a Canon Ixus 80 IS.

When I plug a camera (any of them) into a USB port and switch it on in Play mode, the Autoplay function of Windows 7 starts with this screen:

alt text

I select "Import pictures and videos" to call the native Windows 7 tool. It searches a bit for pictures to download from the camera and starts the transfer.

However, during the transfer, I often get errors like this one:

alt text

The error message is "the following error occurred while importing xxxxxx.jpg", "the file or directory is corrupted and unreadable".

If I use "Try again", it works fine the second time and the picture is retrieved correctly. It's very annoying when it happens 20 or 30 times in a 500-picture download. I cannot leave it running standalone, as I have to watch for the errors and click on "Try again".

Any idea what is causing these errors?

I tried changing the USB port (normally the cameras are connected via a USB hub but it happens also when I connect them directly to a MB USB port) and the USB cable, but no success.

I also checked the SD card by connecting them with a card reader and running a ChkDsk on them but it found no errors on the cards.

Update: No problem when I copy the pictures manually with the Windows Explorer. And no problem either when I access the card with a reader. The builtin import tool of Windows is convenient as it sorts the pictures automatically by date (1 folder per day). And this is the way I sort my pictures.

  • 1
    do you get errors when manually copying the files via Windows Exploerer? did you try to copy from the card reader instead of the camera?
    – Molly7244
    Sep 26, 2009 at 20:13
  • What happens if you use the 3rd option in your dialog (Picasa3)? The reason I ask is, that I have a very similar problem importing to Picasa (since using Windows 7). So far, I thought this is a Picasa bug. Maybe not.
    – user12889
    Mar 25, 2010 at 1:53

7 Answers 7


I just wanted to say I have been having exactly the same thing with my canon 400D. I am also getting similar error messages though when I try to transfer photos from my old pc to the new one on a disk!!..... I am ending up with folders with huge amounts of photos missing because they won't copy to the new pc....


It appears that the problem has been Kaspersky 2010 anti virus....we have just changed to AVG and this seems to have solved the problem.....


Don't think this is a Kaspersky problem, because I have the same problem with 2 different windows 7 computers and 2 different cameras, using 2 different anti-virus. Downloading the same pictures from same cameras with a third computer using windows Vista, I have no problem.


I think the problem might be the speed of the interface.

With the card in the camera and using the camera's USB connection you might only be getting a USB 1.1 connection, but perhaps Windows is trying to read the data at USB 2.0 speeds. This might cause the symptoms you're seeing as the camera can't keep up with the requests from the PC.

When copying manually the delays caused by you (the operator) will mean you don't get this, and when the card is in a card reader you'll be getting the full USB 2.0.

Check if your camera is supposed to give USB 2.0 speeds or not. If it is then try another cable. If that doesn't work then there might be a fault in the camera.

According to page 129 of the manual, troubleshooting section Computer - Cannot transfer images to a computer, you can switch the camera to a lower connection speed:

Press and hold down the MENU button, then press and hold the arrow_up and Func/Set buttons simultaneously. Choose [B] when it appears on the screen, then press the Func/Set button

If it wasn't the cable and if there's no problem getting USB 2 speeds out of the port when connected to something else it sounds like a problem with the camera. Have you tried transferring files to a different machine? I would have suggested that it's the camera, but I've just re-read the question and it seems like it's both cameras that are slow.

The only other thing that springs to mind is getting the Windows 7 version of the camera software/drivers for you PC - if they exist of course. Have you checked the Canon site or done a Windows Update and checked the non-critical updates it suggests?

  • Good idea. However the camera is supposed to support USB 2.0 and so is my computer. Anyway, I'll try with another, better quality, USB cable and let you know. Thanks.
    – Snark
    Nov 25, 2009 at 22:41
  • Well, I had another huge batch of pictures to transfer from the camera to the PC. I used another new, high-quality USB cable but same issue.
    – Snark
    Dec 4, 2009 at 16:32

Apparently nobody has an idea about this issue and I couldn't find anything on the Net.

So, as I couldn't solve it, I made a workaround: an AutoIt3 script that waits for the error message in the window. When it appears, it will select "Try again" and click on "Continue" automatically.

While 1   

    ; wait for the window to appear with a part of the error message
    WinWait("Import Pictures and Videos","What do you want to do?")

    ; activate the window (some windows do not like getting commands if not activated 
    WinActivate("Import Pictures and Videos")

    ; select the "Try again" choice (normally the default but you never know)
    ControlClick("Import Pictures and Videos","",1080)

    ; click on the "Continue" button
    ControlClick("Import Pictures and Videos","",1)


This will allow me to start a transfer of hundreds of pictures without having to watch constantly about the error message.

I don't even have to remember to start it before a transfer. As soon as I get the error message, I can run the script and it will process the current error message and the next ones.

If someone has a better idea, I'll be more than happy to hear from it.


As a few others have said - it is Kaspersky. I am running Kaspersky 2010 and was having the same problem from the built in card reader. When I pause Kaspersky there is no problem at all. I hope Kasperky fixes the problem. Meanwhile I'll pause the protection when I import.


I've been going into the drive (the camera shows up as removable storage), copy and paste the files to a folder on the drive. I expect that this won't work for everyone as a few people have cameras that don't work that way.

Hopefully Microsoft will fix the issue. Oh, my camera is a Canon Powershot SD1200IS and no, I'm not using Kaspersky, I'm using NOD32.

I hope that this helps a few people!


It's definitely Kaspersky on mine. If I pause Kaspersky, then import, the pictures import with no hesitation at all. Then I resume Kaspersky.

  • I don't use Kapersky, I have the problem with NOD33 and Microsoft Security Essentials, even when they're paused.
    – Snark
    Feb 2, 2010 at 8:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .