138

I've install Windows 8 on a BootCamp macbook air The problem is that the command key located differently from the winkey in a normal keyboard, therefor, I keep clicking Winkey+Enter which starts the narrator (which is really annoying!)

Is there a way to disable this shortcut?

3
  • @vcsjones does the existed answer doesn't helped you?
    – avirk
    Nov 26, 2012 at 15:55
  • 3
    @avirk The bounty is "One or more of the answers is exemplary and worthy of an additional bounty." I was really happy to find this, so in 24 hours (when I can award the bounty) I'll give it to the accepted answer (which worked well enough for me). Sometimes I find an answer that is really worth more than an upvote. This is one of those times.
    – vcsjones
    Nov 26, 2012 at 15:56
  • now I know why sometimes windows narrator appears when I press alt+enter to view a movie in fullscreen
    – phuclv
    Apr 11, 2015 at 10:50

11 Answers 11

98
+100

I have not tried it personally but here's what I found.

  1. Navigate to %systemroot%\System32
  2. In this folder a file called Narrator.exe is to be found
  3. Right click the file and choose Properties
  4. Choose the Security tab and press Advanced
  5. In the top of the window press Change to change the Owner permissions
  6. In the text field write your username and press OK to all the dialogs

Now you should be able to change the permissions of the file, this is where we remove all the permissions from your user and change the owner back to SYSTESM; this way your user will not be able to start the Narrator.

  1. Right-click the Narrator file again and choose Properties and Security
  2. Press Advanced
  3. Now that you are the owner you can change permissions for other users. Choose your own user and press Edit
  4. Remove the Read & Execute and Read permissions and press OK
  5. Now press Change in the top under Owner and write system in the text field
  6. Press OK to all dialogs

Source

5
  • 8
    Patchy as hell, but best solution so far. Thanks!
    – Dig
    Sep 21, 2012 at 10:57
  • 4
    Disabling narrator.exe can be achieved much simpler by just renaming the file. Also, it will need to be redone every time it is updated by Windows Update.
    – harrymc
    Nov 26, 2012 at 16:03
  • 5
    Indeed patchy as hell but definitely necessary. It utterly defies belief that there's no way of disabling the narrator completely from the regular UI. That I've found so far, at least.
    – J. Steen
    Feb 18, 2013 at 10:18
  • 2
    see the comment on the other post about doing the same for AtBroker aswell - otherwise you'll get those processes spawning and hanging around when you windows + enter
    – JonnyRaa
    Oct 15, 2014 at 10:25
  • This is the best answer, thanks! All other comments excluded crucial steps for the instructions.
    – Cassidy
    Dec 14, 2021 at 15:24
82

If you're familiar with editing the Windows registry, you can use the solution described here:

  • Launch regedit.exe and navigate to: HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options
  • Create a key with the name Narrator.exe
  • Inside the key, create a new String value called Debugger, and set its value to %1

This won't be changed by Windows updates, and can be easily reverted by just deleting the key.

If you don't use any Windows Assistive Technology features, you may also want to create a registry key for AtBroker.exe with an identifical string to prevent it to be launched as a rogue process in the background every time you accidently use the Narrator shortcut.

6
  • 14
    This should be the right answer IMHO -- doesn't require hacking files.
    – GlennG
    Nov 21, 2013 at 11:13
  • 9
    -1 bad idea. AtBroker.exe starts every time you press the shortcut and keeps on running, sometimes hogging 100% CPU (at least on Win 8.1). Instead, do the same thing for AtBroker.exe.
    – user541686
    May 14, 2014 at 7:46
  • 1
    @GlennG not sure I agree - the registry is a strange and mysterious place - just mucking around with a few file permissions seems a lot simpler to me... although if it does indeed get reset by windows update I might try this
    – JonnyRaa
    Oct 15, 2014 at 10:28
  • 3
    @Mehrdad I've added a line about AtBroker.exe to this answer.
    – user33758
    Feb 3, 2015 at 3:05
  • This also works in win10. Thanks!
    – Jokester
    Dec 14, 2015 at 15:49
16

Pressing the Capslock and the Esc keys at the same time brings up a window that allows you to Exit the Narrator.

4
  • 4
    I was going crazy until I found your solution :)
    – skeept
    Jan 21, 2013 at 21:01
  • Hallelujah! I could not stand the narrator any longer! Thanks.
    – Vaccano
    Mar 24, 2013 at 20:59
  • 1
    I found this shortcut solution elsewhere, but it didn't work for me. Win-Enter did. Nov 12, 2014 at 2:04
  • 4
    This is correct information on how to exit narrator one time, but it does not answer the question, which is how to disable narrator from ever starting again, no matter what keys you accidentally hit
    – JoelFan
    Jun 23, 2015 at 20:55
7

You could use AutoHotkey to disable the Win + Enter key combination with the following script :

#Enter:: return

With AutoHotkey you could also map this key combination to any other key combination or action.

If you wish to disable the Win key itself, see this registry hack :
How to disable the keyboard Windows key.

If you wish to disable all Win + ?? key combinations, this registry hack does that:
Disable Win+X Shortcut Keys on Windows 7 or Vista.

4
  • 5
    I don't want to disable all the combinations, just the one. And I prefer not to depend on third party software such as AutoHotkey, is there any better solution?
    – Dig
    Sep 18, 2012 at 15:32
  • 2
    Not that I know off. AutoHotkey is a magnificent product that can do MUCH more than key-mapping.
    – harrymc
    Sep 18, 2012 at 15:57
  • 1
    I found AutoHotKey and Windows 8 don't agree. I remapped Win+Enter to CloseWindow, and yet 1 out of 20 times Windows grabs the keystroke before AutoHotKey and lunches the narrator when I intended to close a window. Nov 27, 2013 at 21:11
  • 1
    @GuillaumeMarceau: You might try AutoHotkey_L and EnableUIAccess.
    – harrymc
    Nov 27, 2013 at 22:09
2

There is a way to disable shortcuts which start with Win in a windows registry.

  1. Create text file with the following content

    Windows Registry Editor Version 5.00
    
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
    "DisabledHotkeys"=hex(2):0D,00,00,00
    
  2. Change file's extension to "reg"

  3. Run it by double click

As you can see, it creates a registry field "DisabledHotKeys", with a value of a key we want to disable. In our case it's a 0D in hex or 13 in dec or "carriage return" symbol. Win key shouldn't be specified here because it's implied.

For example, if you want to disable Win + R, Win + D and Win + Home then the value of "DisabledHotKeys" should be "RD$". ("$" symbol has an ascii-code equals to a keycode of Home button)

2
2

This probably only works in Windows 10, but the shortcut is really easy to disable now.

Open Narrator (Go to Control Panel > Ease of Access Center > Start Narrator, or use the annoying shortcut), select the Narrator window (it runs in the background), go to General settings and disable shortcut key, click save, and click exit narrator.

1
  • Indeed, Windows 8.1 unfortunately does not have that setting there. Mar 11 at 5:02
1

This is one post that comes up when users search for how to disable Narrator in Windows 10.

This was annoying me today. The provided solutions weren't satisfactory for me. Especially setting the debuger setting. I did a 30 second search for Narrator in the registry and very luckily found this key:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Narrator\NoRoam\WinEnterLaunchEnabled

Setting it to 0 disables the shortcut for the current user, so not in the login screen.

Save this as a .reg file:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Narrator\NoRoam]
"WinEnterLaunchEnabled"=dword:00000000

This key doesn't seem to be present in Windows 8.1, so looks like it's only a Windows 10 addition.

Hope this helps someone though.

1
  • On my Windows 10, the WinEnterLaunchEnabled was not present, so I created it, but unfortunately it didn't work, even after a logout/login.
    – dbernard
    Feb 28, 2017 at 16:08
1

UPDATE 2022

Windows 10 and Windows 11 have dedicated settings just for that.


Windows 11

Windows 11 Narrator settings



Windows 10

Windows 10 Narrator settings



So now it is super easy to turn this Narrator hotkey off.

0

I installed a simple little script program that allows you to snap windows to the edges of screens or to other monitors. By default, I think - I've had this program running for a long while on windows, it takes over the same shortcut key. I installed it on my win8 machine and it seems to have done the trick and taken over the same shortcut used by narrator. I realize win8 has good support for snapping windows around, but I like this shortcut to do it because that's what I'm used to and it has the nice side effect of preventing narrator from starting. You can also do more advanced window placement, but I find I just throw things back and forth to other monitors.

In any case, it's worth a try. I just set windowpad to run on startup so it's always active.

lifehacker link to windowpad article

0

I did the following in my Windows 8 PC to enable and disable narrator,

To enable,

Win + enter

To disable,

Win + alt + enter 

It will bring the narrator screen. Click exit on it.

4
  • Win + alt + enter launches Media Center on my machine. May 23, 2013 at 3:37
  • 1
    Win + alt + enter doesn't work for me on Windows 8.1. Mar 19, 2015 at 9:29
  • Win + alt + enter didn't work for me on Windows 10.
    – Sam
    Apr 29, 2016 at 4:15
  • 2
    These are instructions for starting and stopping Narrator not disabling the shortcut that starts it (please read the question carefully)
    – ndemou
    Jul 7, 2017 at 11:48
-1

I don't know if it works on Windows 8 or not but it works on Windows Vista/7 very well. Press the Win+U key which will open the Ease of access center or you can open it through Control Panel as well.

enter image description here

Now click on the option Use the computer without a display and another window will popup

enter image description here

And unchecked the option Turn on Narrator and click Apply button to apply this settings. Now when you press the Win+Enter narrator won't be start.

4
  • 5
    Nope, That's doesn't work on windows 8. The problem is that those keys actually turns on the Narrator.
    – Dig
    Sep 18, 2012 at 15:28
  • Sadly, not :( It doesn't mention a thing about how to disable this.
    – Dig
    Sep 20, 2012 at 15:17
  • Check this Vista registry hack for Win-8. May be it work and let me know if it does. I'll add it in my answer.
    – avirk
    Sep 20, 2012 at 15:34
  • 3
    That option is not checked, but on Windows 8.1 Win + Enter still starts Narrator. Mar 19, 2015 at 9:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.