I just purchased an MSI 970A-G46 to use with an AMD FX processor I already had. I also got 8GB of DDR3 RAM to go with it and a 120GB SSD. I hooked it all up and put in the graphics card from my old, fried PC. When I turn it on, there are no POST beeps; there are no beeps at all. If I pull out both sticks of RAM, there are two beeps, which is what I expected to happen. However, if I only put in one stick of RAM, it still beeps twice. I tried with both sticks of RAM alone and got the same result. Is there some sort of 8GB-minimum or something? This is confusing me. Also, when I have both sticks of RAM it sometimes beeps twice when it's turning off. Is this a different error? Unfortunately, the manual doesn't seem to have a list of beep codes. The online version is BIOS dependent, and I can't seem to find out what BIOS is on my mobo.

I've reset the CMOS, but it didn't change the results. On the box, it says the BIOS is AMD FX compatible, and I'd like to think they didn't lie (as I've read older versions of the mobo don't come with that BIOS version).

Is my graphics card causing problems? From what I understand, there's no integrated graphics on the mobo, so I have no way to test this. Everything is brand new except the PSU, which worked before, and the graphics card, which also worked before.

  • 1
    If you remove the video adapter, do you get a different set of POST beeps (i.e., "no video adapter installed" per the manual?) – Aaron Miller May 2 '13 at 18:53
  • 1) and put in the graphics card from my old, fried PC.. Are you sure that the graphics card is OK? It might be damaged and worst case it could destroy your new motherboard. 2) Is the CPU marked as compatible? 3) Is the CPU fan plugged in? (Sometimes you have multiple options and some motherboard need a fan plugged into a specific socket). 4) Try again with only the motherboard and the CPU (and obv CPU fan). No memory, no graphics. System start start reliably and give tghe beeps are mentioned by Aaron. If not the board is broken. Either DoA or damaged otherwise (e.g. bya broken addin card) – Hennes Jun 12 '16 at 12:46
  • @smoth190: Can you add the precise CPU model and if possible the motherboard firmware (also called EFI or BIOS) version? – Hennes Jun 12 '16 at 13:00

Usually you can use 1 stick of memory at a time to test. You may need to buy a cheaper video card to rule this out, or a dedicated video card instead using a PCI connection.

It could be that the PCI-E slot for the video card is bad. If you have another 4x PCI slot you could use it to test and verify that its not slot related.

I would suspect its a junk motherboard. I recently bought a MSI board, a mid-line and it didn't even beep for me. I went through two of them with the same issue before getting fed up and got a different brand of board with built in diagnostics.

You may want to see about getting a POST code reader card - they are usually less then $25.

  • Will a broken video card cause it to not post? I've had problems with MSi, but I couldn't seem to find an in-stock board that supported the hardware I already had... – smoth190 Sep 12 '12 at 23:45
  • many things can cause the no boot situation. unfortunatly with as pathetic if existant the post beeps are in msi you will probably spend the least by getting a post card that will have a newmeric readout and a code book that tells you exactly what the pc is doing. If you happen to have spare parts or can borrow things like a cruddy old video card its a way to get around not having a post code reader. in my case i have about 10 carcases that i can steal parts from to test. as long as slot1 on your system board isnt dead memory can be tested to. – Kendrick Sep 13 '12 at 1:57
  • try 1 stick in slot 1 if it doesnt boot try stick2 and see if its any different. if not its probably not the memory. it may also be possible to test in a known good system as well. cpu you will be hard pressed to test unless you have another system around to swap with. I am not the type to swap cpu's though they have to many pins that are easily bent. It all ends up in if msi decideds to play games when you try to rma it. If you cant say it is .. causing the problem its not unusual for you to get the run around from support. – Kendrick Sep 13 '12 at 2:21

It could be that the motherboard doesn't have support for the CPU you're trying to use - look up in the manual and see if you need to update the BIOS before using the CPU you're installing on the board: https://www.msi.com/Motherboard/support/970A-G46.html#down-manual

Take a look here and see if your processor is mentioned in any of the BIOS updates as "added support for..": https://www.msi.com/Motherboard/support/970A-G46.html

  • Can't comment on others due to "Low reputation". Thought it would be helpful as I had this identical issue with an Intel motherboard and i5 CPU. – Kārlis K. Jun 12 '16 at 12:48
  • Not doubting that it is useful. I almost put an URL to compatible CPU's in the comment I was posting but I hit the char limit on comment length. It is likely to get flagged as 'not an answer` though. – Hennes Jun 12 '16 at 12:52
  • I was actually in the process of looking up the Support page for those links, it would've been helpful if the CPU model was specified in the issue description. – Kārlis K. Jun 12 '16 at 12:53
  • It would be. If you have enough rep to comment then asking for the precise CPU model in a comment on the original post would be the way to go. (I'll ask and maybe we get an answer which we can use to point out why it does not work.) – Hennes Jun 12 '16 at 12:59

Try running it alone, everything unplugged but the bare minimums. No VGA? I'd figure there's no HDMI on the MOBO, but you'd think there's a VGA port.

It should POST without memory or SSD. See if it POSTS and then if you can write down the BIOS name and version. You'll be able to compare that to the lists of compatibles with AMDs.

BIOS settings may be holding it all up, like any other setting but SATA will mess up my system and it will go into a loop at boot, even though my drives will do more than the BIOS allows for. I have to set it on SATA with no enhancements.

  • 1
    Just a note, AMD FX processors do not have an iGPU. – TheKB Jun 12 '16 at 9:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.