It's a Windows 7 box that used to work fine. All of a sudden though, it will no longer register DNS with our AD servers. No errors reported. If I force it with ipconfig /registerdns, it will register once, then it goes away once the standard expiration occurs. All our other machines stay registered all the time, it's specific to this one computer. It's kept current on MS patches, nothing real notable about it otherwise. It's a dev station with Netbeans & Visual Studio as well as supporting items.

  • Have you tried to wipe and reinstalled everything?
    – Ramhound
    Sep 13, 2012 at 12:07
  • Nope, Not worth a couple days of downtime reloading all the dev stuff... I can just set a static for now. I still would like to fix the root cause though if possible. Sep 13, 2012 at 14:14

2 Answers 2


Magically started working over time. Both server and client have had patches applied, so I'm unable to narrow it down, but believe that a patch fixed it.


It's probably not a problem with the DNS or even with Windows 7, but with the IP address your computer is picking up. Your computer gets it from a device running a service called DHCP that hands out IP addresses along with the gateway address and the DNS address. If you're connecting to the Internet via a wire to a router then the router is almost certainly where the DHCP service is. If your machine cannot get any one of the three things the DHCP service hands out- the IP address for the computer, the gateway address (which in this case would be the address of the router), and the DNS address, your system won't work regardless if the other two are correct. If you do an IPCONFIG /ALL and the first two numbers of your IP address is 172.169 (the third and fourth numbers won't matter), this is exactly what is happening. 172.169.x.x is the assigned garbage address computers use when it can't get a good IP address from DHCP.

The two main causes for this are...

a) DHCP only has a set number of IP addresses it will hand out, so if you have, for example, six machines and DHCP only has five IP addresses to hand out, the sixth machine will never get an IP address. If you can get the first machine to work by running an IPCONFIG /RELEASE on a second machine that works and then running IPCONFIG /RENEW on the first machine, this is exactly what's happening. If you're plugging your computer into a switch rather than a router, it will never work because your internet provider is running the DHCP service, and internet providers only give you ONE IP address and it's already been given to the other machine. If this is the case you need to log into your router to increase the number of addresses your DHCP service hands out. If you work at a large company with a dedicated server running DHCP, I'll wager you'll find that every single available IP address has been assigned.

b) The cable you're using to connect ot the router has a break in it. If there are any obvious folds or damage on the cable, then this is almost certainly what happened. Another possibility is that your cable runs too close to an open electrical outlet which is causing electromagnetic interference with the signal the cable is carrying. If that's the case then replace the cable or move the cable at least six inches away from any open outlet.

  • If he was getting an APIPA address, he would not be in communication with DHCP or DNS. Obviously, he is getting an address and registering with DNS. The issue is something else.
    – Keltari
    Sep 14, 2012 at 16:06
  • I get DHCP just fine (served off our Cisco ASA). The problem is that my DNS name isn't registering in our Active Directory servers unless forced. When forced it goes in at first, but later on disappears/expires. Sep 17, 2012 at 12:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.