I have a USB 3.0 hard disk which has always been working on my desktop with an XHCI.

Now I just bought a notebook with an XHCI (something with Intel's Ivy Bridge setup). The first time I plug the hard disk in its 3.0 port it is detected and working.

A few hours later I try to connect it again, but seems that the notebook just ignored it! The light on the hard disk didn't blink as usual (instead it is hold at on).

I then tested it with my desktop again and it is working perfectly. It gets trickier when I plug it in the USB 2.0 port of that notebook it is detected and working perfectly (despite the slower speed).

Then I try to plug in an USB 2.0 USB flash drive to that USB 3.0 port, and it is detected (of course as USB 2.0).

So, there are two USB 3.0 ports on my notebook's XHCI. Both of them are not working with my hard disk but working perfectly fine with my USB 2.0 UFD. What's wrong with it?

When I plug in the hard disk, device manager doesn't change. I've tried re-installing the driver for the XHCI, but it changes nothing. Had I broke the USB 3.0-specific pins of both USB 3.0 ports?

Edit: OS = Windows 7 x64

  • Please edit the question and indicate your operating system. I'm guessing some version of Windows from the reference to "device manager". – allquixotic Sep 13 '12 at 15:36

That's fine, I figured out what's the problem.

On the first boot, it's fine.

Then I rebooted, entered UEFI BIOS, and enabled VT-d (which is totally irrelevant to USB 3.0 options).

USB 3.0 doesn't work after that.

Solution: Entered UEFI BIOS, changed USB 3.0 setting from Auto to Enabled.

I swear I didn't changed the USB 3.0 setting when I first entered BIOS!
Still I have no idea why the default option didn't work... even it worked for the first time. :P


Make sure your motherboard drivers are up to date. Visit the motherboard manufacturer and download mobo-appropriate drivers. The computer manufacturer doesn't necessarily provide the latest drivers, even if the latest ones from the upstream manufacturer are compatible.

  • Thanks, I didn't checked updates because I was planning to install my own copy of OS. I am only trying to backup the OEM recovery. Anyway thanks for your help. – Alvin Wong Sep 13 '12 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.