0

I have the XFCE desktop manager installed on my Arch Linux system. With E17 (Enlightenment desktop manager) I had no problems with my mouse: all buttons worked correctly out of the box. But in XFCE my middle mouse button does not fire an event at all (no output with xev).

Evdev seems to identify my mouse correctly (Razer Deathadder) because it echoes its name in the xorg logs. I have no idea what could cause this and how to debug the problem.

I start both E17 and XFCE with startx. Here is my ~/.xinitrc:

exec startxfce4 --with-ck-launch
#exec enlightenment-start
2
  • How do you start xorg and XFCE? Does the problem occur if you first use xinit, then startxfce4? If so, at what point does it happen? What if you start XFCE from inside E? Are the same events mapped to the same buttons otherwise in E and XFCE?
    – Eroen
    Sep 13, 2012 at 17:08
  • I added some information to the question. Is it even possible to start XFCE from inside E? I'll try xinit later.
    – Alp
    Sep 13, 2012 at 17:20

2 Answers 2

1

See the ArchWiki page for Razer input devices.

The razercfg site link there is out of date, so download it from the developer site. Your device appears to be fully supported.

The razercfg and razercfg-git AUR links that the wiki mentions are also currently out of date, so don't waste your time with those until the packagers update them.

3
  • Nice idea, but sadly i can't get it to run. Neither the official version, nor the AUR packages work after installing them: > razercfg File "/usr/local/bin/razercfg", line 143 except (ValueError), e: ^ SyntaxError: invalid syntax
    – Alp
    Sep 20, 2012 at 16:44
  • That sounds like you have a python version mismatch. Do you have python2 installed? What did you do to get the AUR packages to install? Maybe some needed dependency isn't being enforced in the PKGBUILD.
    – zero2cx
    Sep 24, 2012 at 5:00
  • yes i have python2 installed
    – Alp
    Sep 24, 2012 at 7:58
1

If the problem is HW related (did you try the mouse on another PC?), here is what worked for me.

I had the same problem with a Logitech G602 mouse. The issue was with hardware button. I opened the mouse (mine has screws hidden behind plastic pads) and put some WD40 on the button just below the wheel. I let it dry a bit, move and used the button several times and added again some WD40 and repeated the click and shake of the button. I reassembled the mouse and voila! the middle click button is working again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.