I get the following error message while accessing Windows 7 shares from XP.

System error 58 has occurred. The specified server cannot perform the requested operation.

Both machines are in same domain. Windows XP machine can view and access all other shares except Windows 7. Neither machines have a firewall.

  • Have you checked windows 7 shares and confirmed they are allowing access to your username or usergroup?
    – A Dwarf
    Sep 27, 2009 at 1:57
  • yes. same users is logged onto both machines. not even net view works.
    – nysingh
    Sep 27, 2009 at 3:22
  • 1
    Restarting the Server service in Windows 7 was enough to fix my problem.
    – user79246
    May 1, 2011 at 17:08
  • 1
    Stopping and restarting the sever service on the Win 7 x64 box allowed the XP machine to connect to the share hosted by the Win 7 x64 box. This was definitely less traumatic than any other fix. This problem seems to come and go, supporting the thesis that there is some kind bug that can be eliminated temporarily, but always comes back eventually.
    – user240389
    Jul 24, 2013 at 13:29

7 Answers 7


Changing the NTLM settings in the Local Policies did not work for me.

What did work is mentioned here: link text

...you need to tell Windows that you want to use the machine as a file server and that it should allocate resources accordingly. Set the following registry key to ‘1′:

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache

and set the following registry key to ‘3′:


After changing the two registry settings, I simply restarted the "Server" service in Windows 7 and now the sharing is working fine.


ok guys here is the answer.

the problem was NTML response was not setup on both sides. I had to setup following on both xp and wind7 and a restart did the trick.

  1. GPedit.msc
  2. Windows Settings. Expand “Local Policies” and select “Security Options”
  3. Alternate : Type secpol.msc to get editor up then
  4. Locate “Network Security: LAN Manager Authentication Level” in the list and double-click it.
  5. Change the setting from “Send NTMLv2 response only” to “Send LM & NTLM – use NTLMv2 session if negotiated”

It might be helpful to also know the exact cause, before you pick one of these solutions. I recently had this same issue while trying to synchronize files from a Windows 2003 Server to a Windows 7 workstation. At random, the server would lose its connection to the Win7 box, and attempting a NET USE command to map a drive would return a Status 58 like this.

Rebooting the Win7 box would fix it, but this seemed drastic. Looking deeper with Wireshark, we found that an SMB request was going to the Win7 box, and an SMB reply "Out Of Memory" was being returned. Stopping and restarting the Server service on the Win7 box resolved the problem, at least temporarily, and is much better and faster than a reboot. I expect that the registry changes for the large system cache will resolve it completely, but these changes may not be suitable to a permanent change, just to get past a temporary issue.


System error 58 means that authentication failure happened - at least I get this error if I mistype my password.

I encountered the same problem too. I was given a network share name, and username and a password to access it. I tried it, but failed. The computer is in our network so it must in our domain too...

The problem was that I was in the X domain, so it automatically tryed to log me in using X\username. Of course such username doesn't exist, because the actual user I needed to use is Y\username, because the department who created the user was in the Y domain so they didn't noticed this and worked for them.

Things learned: always tell which domain the user is in, if you are given domain credentials.

(hope this helps out someone, who stumple upon this.)

  • This advice is a lifesaver! I have successfully mounted share with specifying username and password in net use command like this: net use z: \\\some_folder /persistent:yes /user:"my username" "my password"
    – Kyo
    Mar 10 at 11:24
  1. Make sure that the Windows firewalls are really off, turn off all antiviruses and also turn off simple file sharing. Sometimes this helps with error 58.

  2. Try to install the Link Layer Topology Discovery on the XP machine.

  3. The problem might be account permissions, on which Win7 is quite strict. Check permissions on the share.

  4. And last : are all machines fully patched?

  • 1. all firewalls are off. 2. will try link layer topology 3. no permissions issue. even domain admins get the same results (error 58) 4. all machines are fully patched.
    – nysingh
    Sep 27, 2009 at 18:37
  • link layer topology discovery is installed. no luck.
    – nysingh
    Sep 27, 2009 at 19:14
  • Have you tried turning off simple file sharing? Does ping succeed (1) with machine name (2) with IP address ? What happens when you try accessing the shares by Win7 IP address?
    – harrymc
    Sep 28, 2009 at 6:22

I encountered same issue recently while trying to access a windows 7 share from windows xp sp2. I could reach other shares on windows vista and xp but no windows 7 even though I was able to see it i couldn't access it. After much troubleshooting I found that the windows 7 system belonged to a Homegroup. Once I removed (or left) the the Windows 7 system from the Homegroup I was then able to access the share with the proper credentials. Hope this helps anyone else that may encounter similar issue.


For me it was that SMB was disabled.  I ran these commands in Command Prompt with elevated rights:

sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
sc.exe config mrxsmb10 start= auto

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.