I am trying to setup a Linux Mint 13 system using mdadm, with 2 1TB hard drives for a software mirror. I have tried following instructions found for Linux Mint 12, but the instructions fail to mention how to fix the Cannot install GRUB to /dev/sda error, even when I select the /dev/md0 volume as where I wanted the boot loader in the Setup. Hardware RAID is not an option on this system

I finally decided to just install Linux to the first hard drive, and now I would like to setup the RAID from the hard drive that is currently working. Is this possible? If so, how?

I would appreciate step-by-step commands, as I'm more of a Windows/Mac user then a Linux user, but I do understand and check commands I learn from Linux before typing them

EDIT: The customer asked me to just install on one drive and he'll run a script to dd from that drive to the other as "backup"

  • I believe RAID is usually setup in the BIOS which shouldn't be affected be your OS. – imtheman Sep 13 '12 at 22:26
  • @PeterMaxwell The customer specifically asked for a Software RAID setup – Canadian Luke Sep 13 '12 at 22:31
  • Have you looked at this? forums.linuxmint.com/viewtopic.php?f=46&t=107460 – cutrightjm Sep 13 '12 at 23:30
  • @ekaj Tried, but it didn't work. No manual grub install was offered. The installation failed, and it looked as though it didn't keep the installation on /dev/md0 – Canadian Luke Sep 13 '12 at 23:34
  • Do the drives have valid partition tables? – Yedric Sep 17 '12 at 16:41

Follow these directions here and you should be good to go.

  • Currently trying the link, but could you please post the step-by-step instructions here as well in case their site ever goes down? – Canadian Luke Sep 17 '12 at 18:55
  • As a quick status update, looks like the array is "building" itself, which may have been why it stopped in the first place. Once it's done rebuilding, I'll add the FS to it and retry the installation – Canadian Luke Sep 17 '12 at 19:17
  • best of luck to you! – Keltari Sep 17 '12 at 19:24
  • Got through the installation, but now I'm dropping down to a BusyBox v1.18.5 system at the (initramfs) prompt, and I don't see any dev/mdx or /dev/sdx devices – Canadian Luke Sep 17 '12 at 22:37
  • Unable to verify; can't take back the bounty so I may as well award it – Canadian Luke Sep 18 '12 at 19:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.