I am using a certain file type (.QTZ) which I have successfully linked to an application. When I double click, the correct application starts. However, in Windows Explorer, it still says it is a "QTZ File".

How can I change that type description? I have found the "Default Programs" tab in the Control Panel, but it only lets me edit associations, not file types.

  • Launch regedit.


  • In HKEY_CLASSES_ROOT, find your extension (you just have to type .qtz). Example with .ods file:


  • Look for the Data of the (Default) value (in my case, opendocument.CalcDocument.1, but in yours, something related to your application), and find this name in HKEY_CLASSES_ROOT again, by typing the first letters. Example with opendocument.CalcDocument.1:


  • Change the Data of the (Default) value to the description you want.


  • Close regedit.

To see your changes appear, you can either reboot, or change the default association of some file by choosing "Open with > Choose default program..." (I couldn't find the proper method). Here is the result:


  • 1
    The (slightly) easier way to apply the changes is to kill the explorer.exe process using Task Manager, then File > Run new task and type explorer to reboot it. – ArtOfCode Aug 1 '16 at 17:29

You can also use NirSoft's GUI-based FileTypesMan utility. It's available for both 32- and 64-bit systems.

  • Use Ctrl+F or Edit -> Find to find your file type
    • Searches by any field available. See the Edit File Type dialog below.
      • Include the . for faster extension searches, such as .script
  • Edit properties as desired.
  • Toggle advanced options as desired.
  • Click OK.

FileTypesMan Edit dialog

Pretty great, flexible, and very easy.



The solution proposed by m4573r used to be the only way to do this up to Windows XP but doesn't always work in Windows 7 if file extensions are first associated with a program from Explorer (when using "Open with >").

In such cases you might have to navigate to the following registry key:


and change the (Default) value directly under your file extension registry key.


All my video file types were "MediaPlayerClassic-HC" files, regardless of the extensions (mov, mp4, wmv etc...). To avoid this, you should associate the files directly in MPC-HC "View/Options/Formats" instead of using "Open With" and "Choose Default" in Windows Explorer.


After changes on HKEY_CLASSES_ROOT , open task manager > processes, then select explorer.exe, end process button , go to applications tab, press new task button, write explorer.exe, and can see new filenames on type name.

  • 1
    In which way is this better than accepted answer? – Toto May 25 '18 at 12:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.