Recently when I open windows services (always as administrator) I get a blank list of services:

enter image description here

When I try and click on one of the empty lines I get this "Script Error" message:

enter image description here

This happens over and over again, after several times I restarted my computer. I can't pinpoint exactly when this started happening or if I made any specific changes to my computer at that time.

Someone told my to try running scf /scannow as administrator, but when I try to do that the scan stops at 34% and I get the message: "Windows Resource Protection could not perform the requested operation."

I am running Windows 7 Enterprise 64 bit, and I would really like to avoid reinstalling windows.

Does anyone know how to fix this?

Edit - Here is another attempt I made and some more information that might help:

Following WhoIsRich's suggestion, I tried the command sfc /scannow /offbootdir=c:\ /offwindir=c:\windows.
This gave the error message "The arguments passed to sfc are invalid. The offline windows directory specified points to the online system", and then I realized this command is meant to be run after booting from another system.

Since I don't have my windows installation disk right now, I used my own system to create a recovery disk, and then restarted my computer and used the recovery disk to boot.
I then ran the above command, and I got the following message: "Windows Resource Protection found corrupt files but was unable to fix some of them. Details are included in the CBS.log".
I then restarted my computer and let it boot up normally. The problem with windows services persists, and the CBS.log file is a long log file with many entries, and I don't know if there is useful information in it, and if there is, how to find it.

  • Is this shortly after you restart, or random intervals? Often after a reboot, the computer hasn't started everything up quite as fast as you'd like and things will be empty (prime example is the User column in the Task Manager's Processes list). – user3463 Sep 14 '12 at 17:26
  • This happens also when a long time has past since I restarted. – Joe Sep 14 '12 at 21:27
  • You may have to back up your data and reinstall Windows :-( – user3463 Sep 15 '12 at 0:59

I would first run a ChkDsk /R to find out if your hard disk has bad sectors.

You may want to try the suggestion: sfc /scannow /offbootdir=c:\ /offwindir=c:\windows

If you run Task Manager, Windows 7 has a services tab, worth checking to see if its the entries or just the viewer that is screwed up.

  • I just ran ChkDsk /R and the problem remained. When I run the Task Manager and switch to the services tab, all the services are there and everything seems to be OK. I will try and read the article you linked to. – Joe Sep 14 '12 at 21:34
  • When I try and run the command you suggested I get an error message: "The arguments passed to sfc are invalid. The offline windows directory specified points to the online system". This problem is also reported in one of the responses to the post you linked to. – Joe Sep 14 '12 at 21:51
  • I figured out how to properly run the command you suggested (after booting from a recovery disk), but this led to another error message - I added the description to my question. – Joe Sep 14 '12 at 22:32
  • As I run the same edition, SP1, have a look if 'windows\system32\mmcndmgr.dll' is the same: 3,207,168 bytes for size on disk, and has a MD5 sum of 9E3C848BBDB5521271B3B038ECE8CC88 ( using the HashTab addon. ) – WhoIsRich Sep 15 '12 at 2:50
  • 1
    My mmcndmgr.dll had the exact same size but a different MD5 sum! Since I have a computer at work with the same OS, I connected to it remotely and got its version of the same file - it has the correct MD5 sum. I booted my computer from the recovery disk again, replaced my file with the one from my computer at work, restarted - and the problem is solved! I didn't even have to download the W7 ISO, Woohoo! – Joe Sep 15 '12 at 7:38

Windows Resource Protection could not perform the requested operation.

Yikes. Sounds like even the files that WRP uses as a backup were overwritten or corrupted. From the look of it, you may have physical HDD issues (losing data) or a virus or malware.

You could probably extract the text of that javascript file out of mmcndmgr.dll and determine the local source of the problem, but most likely the source is general data corruption or malware/virus, not a bug in Microsoft's code.

  • On the one hand my problem is alarming, but on the other hand everything else on my system seems to work perfectly (other than an occasional performance issue, which I think is not related to this problem). How would I go about extracting the text of the javascript file out of mmcndmgr.dll? – Joe Sep 14 '12 at 21:37
  • I used ResourceExtract to do it on my system, and it worked. Just point it at C:\Windows\System32\mmcndmgr.dll and tell it to extract everything and the output will be mmcndmgr_VIEWS.JS. Line 40 here is strNodeType = curNode.Nodetype; – allquixotic Sep 14 '12 at 21:49
  • Yep, I tried it and I have exactly the same. I didn't solve my problem, but it's nice learning something new! – Joe Sep 14 '12 at 22:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.