My Windows 7 machine infuriates me. It cannot hold a date. At one point it all worked fine, but now it will decide that it needs to change the system time to a random time and date, either in the future or past. There seems to be no correlation or set interval of when it happens.

In attempt to remedy this, I have:

  • Correctly set the time in BIOS.
  • Replaced the motherboard battery with a new CR2032 (even checked it with a multimeter).
  • Tried disabling automatic internet synchronizing via "Date and Time" dialog.
  • Stopped, restarted, left disabled the Windows Time service.

Yet with all of these actions, the time will continue to change.

Also, the machine has OS X and Ubuntu partitions. It does not occur on either of those so I'm fairly certain it's not hardware related.

Any ideas?

Edit: This is a fairly old post now, but I thought it warranted an update. I never solved the problem. I ended up reinstalling Windows 7 and the problem went away (still had OS X and several linux partitions running just fine; also had the same hardware). Just another mystery of Windows, I suppose.

  • Have you tried changing the time synchronization server?
    – imtheman
    Sep 16, 2012 at 19:26
  • Yes, Peter. The time will sync to the correct time. But after an indeterminate amount of time has passed, it will randomize again. Sep 16, 2012 at 21:17
  • When it randomises, is it still sync-ed?
    – Andrew
    Sep 17, 2012 at 11:06
  • Yes, it randomizes when sync with internet time is checked or unchecked. Sep 19, 2012 at 18:38
  • 2
    Does this also happen when the machine is completely offline?
    – Langhard
    Sep 20, 2012 at 6:45

11 Answers 11


This problem is very frequent and can have many causes, not all of them are known.

You already did the obvious, which is replacing the on-board battery, so only unobvious reasons remain. Some I can think of are :

  1. Your time-server is bad, so change the one you are using by right-click on the clock / Adjust date/time / Internet Time / Change settings.
  2. Check the date/time of your router - sometimes this affects Windows.
  3. Reinstall Windows - this was the only solution for some people to undo the corruption.
  • 1
    The problem still occurs even when Internet Time sync is off. I guess I'm leaning towards number 3 here, which is very annoying since I'm afraid that a clone will carry over whatever is causing int. Sep 23, 2012 at 19:10
  • If you still have this problem after reinstall without too many non-Microsoft applications, then this might still be a hardware problem after all.
    – harrymc
    Sep 23, 2012 at 19:53
  • 1
    My bet is that it will go away after I completely reinstall Windows. However, as I said before given that I can't just clone the installation this will be a complete pain in the ass. Excuse the french. Sep 26, 2012 at 6:17
  • Bonne chance, Jonathan.
    – harrymc
    Sep 26, 2012 at 6:34

Try using a linux livecd and see if the problem persists. If it does not, then you know its a problem isolated to Windows. If it does, then it points to faulty hardware.

  • 1
    I forgot to mention that. The machine has OS X and Ubuntu partitions. It does not occur on either so i'm fairly certain it's not hardware related. Sep 16, 2012 at 21:16
  • @JonathanDumaine: does the time change while powered on and running, or after a reboot/resume?
    – horatio
    Sep 20, 2012 at 20:59
  • If you go for this, watch -n1 date is your friend. Sep 22, 2012 at 16:34
  • @horatio Both. The time changes periodically while running normally, and upon boot it chooses a random time and sticks with that. I should note, however, that once it chooses a random time, it sticks with that time. It won't change again until I reset the clock to the correct time. Sep 26, 2012 at 6:20

It's possible the Windows Time Service has gotten confused. Run cmd.exe as an administrator (Start -> All programs -> Accessories -> Right click command prompt, then run as administrator) and type these commands to reregister and restart the service. I found some reports that it worked and some that it didn't on this particular problem.

net stop w32time 
w32tm /unregister 
w32tm /register 
net start w32time 
w32tm /resync
  • Thanks for the link. Definitely didn't work on my system. net had no trouble stopping Windows Time, but then when I tried to /unregister and then start it back up, gave me an Access is Denied and then said that the w32time service it had just stopped no longer existed to start up again. -__- Sep 17, 2012 at 3:49
  • What happens is if you reboot before issuing the failing command? Sep 17, 2012 at 4:11
  • 1
    Rebooting and reopening an elevated prompt got the commands working. However, even after leaving Windows Time disabled, the clock is still changing periodically. Sep 19, 2012 at 18:38
  • This is equivalent to PC restart.
    – Gravity
    Mar 9, 2016 at 12:32

In some versions of windows, especially those sold abroad, if the license is not properly registered and windows thinks it might be a pirated copy, this is a common phenomenon. Check that you are using a properly licensed copy of windows. It was one among several "annoyances" that windows started to do, short of disabling itself, to encourage proper licensing by the user.

  • 3
    Tremendously interested in any possible source you may have on this.
    – LawrenceC
    Sep 26, 2012 at 0:51
  • 1
    My Windows install says it's validated just fine. I would also be curious to see a source for this. Sep 26, 2012 at 6:21

I came across very similar issue few months ago and it took me quite some time to fix it. I tried pretty much everything suggested here. I had:

  • Windows 7
  • Ubuntu 10.04

The BIOS was set in UTC time. Windows kept putting itself to that time zone, no matter what I did. Even if I changed the BIOS time setting, it still was changing after some time.

So, I found this useful how-to that showed me how to set the time properly when dual-booting from Ubuntu help site, and I believe this will help you.


Does this happen only when you are connected to your router? Check whether you have set the correct timezone and daylight settings in your router.

  • Checked. Router has correct settings. Ten other computers connected to the router and happens on none of them. Sep 23, 2012 at 19:06

On the off chance you have not already done this, run a thorough virus scan. Preferably by a different virus canner than the one you have installed.

Also try running a virus scanner from OSX or Linux.

  • Would you suggest any specifics solutions? I've run full scans with Norton, AVG, Trend Micro and MS Security Essentials (my go to AV). Sep 26, 2012 at 6:18
  • Sorry, not very knowledgeable on virus scanners. I would try and run something like CLamAV from Linux or ClamXav from OSX though.
    – terdon
    Sep 26, 2012 at 11:17

Well , the problem that you have mentioned , I also came across it , when I had Ubuntu installed alongside Windows . I was using WUBI installer from Ubuntu . It was so annoying that I stopped using Ubuntu alongside Windows . I started using Linux Virtual box , and I did not had the problem related to time since then .So, I think there might be an issue with the way the Linux distribution updates the time . Check where you have set your location in your Linux distribution , whether or not you have enabled daylight saving scheme and/or the auto time update/sync option.

  • I imagine that if you're not booting one then the other, it shouldn't matter what or how many partitions you have alongside Windows. Sep 26, 2012 at 6:16

I think about 2 ways.

1)The problem can be your CMOS. Try to enter your PC's motherboard's official site and find solution there, or simply, Google it!

2)Or maybe that's a simple type of VIRUS. By default that type of virus is not catched by antiviruses, because they decide that changing time by programs is not dangerous for your PC, while changing time can remove your antivirus activation key and let the virus download and run his other viruses. Try these steps.
2.1)Check autoruns from msconfig.exe (Start->Run->msconfig.exe)
2.2)Try to check all autoruns thoroughly with Sysinternals's Autoruns. It shows all autoruns, which are not shown in msconfig.

  • I looked through my autorun entries and did not find anything out of the ordinary. Just in case, I disabled just about everything non-system related to see if one of them was the culprit. Was not so. Sep 26, 2012 at 6:15

I had this issue once when I was seeding a torrent. My assumption at the time was that the leecher was attempting to connect with an improper time/date. ( I stopped seeding and it stopped) This will occur when two networks attempt communication with differing times. It more than likely is a network you are talking to or a network that is trying to talk to you. (think application updates). It would be a tedious task to try and list all the programs you have that talk to the network so try and eliminate the applications' access that YOU think would be most probable.

  • 2
    I don't see a torrent connection affecting your system time. Your situation may be very localized Sep 26, 2012 at 2:43

The problem with my sister's laptop was that the battery keeping the clock running was dying, so the clock would reset to like 2007 every time she would wake up or restart the computer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.