I experienced this week that the keys F1 - F12 isn't functioning any more in any application. I can't think of any big changes I did to the computer that would cause this.

There was some Windows Updates, but I think it was there before that and none of the updates said to be related to the keyboard.

I have rebooted several times while trying to work out what's causing it.

The keyboard is a wireless full size Microsoft keyboard for a desktop computer running Windows 7 64bit.

I'm wondering if there's an application that's claimed the keys for some functions. (All though - nothing appear to work when pressed.)

Any tools to diagnose keyboard issues like this? Inspect global shortcuts?

Something that would be quicker and easier than disabling all statup apps and enablind them one by one (that will just take a very long time.)

10 Answers 10


Most newer microsoft keyboards have a function lock button and by default have the function keys used for multimedia keys. Does your keyboard have such a button? If so, you just need to push the function lock button.

  • @thomthron this is probably the most likely problem.
    – cutrightjm
    Commented Sep 16, 2012 at 19:19
  • Some laptops have a key that determines whether the top row of keys act as function keys or the normal top row of a querty keyboard. Make sure that hasn't been toggled...
    – martineau
    Commented Sep 16, 2012 at 19:20
  • Ah! Yes! I never noticed that! An "F Lock" button to the right of the F12 button. I never use the F-keys that's that far up. I do feel silly now for not seeing that. I never cared for extra function keys on keyboards except multimedia keys. In fact, I searched a long time to find a full keyboard where they keys where not moved about with a set of multimedia keys to control audio. Ignored the optional behaviour of the F-keys which I really only thought of as a laptop thing. All it good now - nothing to see here. Thanks for your swift response.
    – thomthom
    Commented Sep 16, 2012 at 19:27
  • This was the solution for me, using a Microsoft Natural Ergonomic Keyboard with OSX. Function keys like F5 suddenly stopped working. Apparently I'd toggled "F Lock", which is next to F12. Commented Jan 21, 2015 at 14:25
  • Official thread on the topic: support.microsoft.com/en-us/kb/894513
    – colan
    Commented May 6, 2015 at 14:25

Do they function outside of Windows? Can you cold boot the computer and hit F1, or whichever, key to go into BIOS?

Try booting off a Linux livecd and see if the problem still occurs. If they do, then you know the problem is hardware related.


Does your keboard have an fn button? if so, try fn+F4, etc.


In my case, I have no F-Lock key.

It was a loose USB RF-receiver for my wireless keyboard.

I tried multiple keyboards on the same receiver before realizing I had to unplug the receiver and plug it back in again.


My keyboard has the Mode button in its top right hand corner (Couger keyboard). When I pressed this it re-enabled the function keys.


On a HP windows 8.1 system, you can hold down the start button in your keyboard and press the Fn key. It works just like the F-lock key.


If you have to use SetPoint for your keyboard, sometimes you have to kill the setpoint process and restart it for your function keys to work. Great code!


I had the same problem with HP Windows 8 but I didn't have the FLock option on my keyboard but I held the Windows button located under the 'Z' key along with my Fn button and it worked like the FLock and problem solved.

Hope this helps anyone with the same issue!


Holding down the Win button on the left side of my space bar along with the fn button to the left of the win button worked for me.


i had a problem like this none of my f-12 keys were working but it was because my computer has something called quickset and it was set to functions row instead of multi-media all i had to do was press esc and fn at the same time to set it to mullti media

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .