19

When browsing a certain site I keep getting a prompt asking me:

Do you want to allow this webpage to access your Clipboard?

If you allow this, the webpage can access the Clipboard and read information that you've cut or copied recently.

enter image description here

If you pick Allow/Don't Allow the message will come up the next time you go to the web site.

How can I set a default action to prevent this from popping up every time I hit this web page?

2 Answers 2

19

You can set a default action to hide this prompt from the Internet Options menu. Go to menu ToolsInternet Options, and then open the Security tab. You can set a default for either general Internet sites, Trusted sites or Restricted sites. For information on why you see this prompt, and why by default you should not allow clipboard access, see this MSDN article.

If you want to allow access to your clipboard, add the site to your Trusted Sites (and make sure you actually trust the site, since allowing this option can allow them to copy clipboard information, like passwords). If you want to just disable clipboard access by default, just pick Internet to automatically disable this option everywhere (it's quite rare that it will be requested).

Click the Custom Level button and then scroll down to the Scripting settings; you can set a default for Disable or Enable for Allow Programmatic clipboard access.

Enter image description here

Here I trust the site, so I've added it to my Trusted Sites list and set a custom level only for Trusted Sites to allow this option. You can also disable this option if you don't trust the site or don't need the feature.

4
  • 4
    I'd really appreciate if you'd note how dangerous "silently allow" option really in front on your answer. Because just one malicious site in allowed list means "bye-bye all the passwords from password manager that are conveniently extracted through clipboard". Sep 17, 2012 at 15:52
  • @OlegV.Volkov made it a bit more explicit you should default to "disallow" unless you're setting this only for trusted sites
    – Ben Brocka
    Sep 17, 2012 at 16:36
  • 1
    Any ideas why this wouldn't work? I have this setting to enable for all zones (other than restricted sites) yet I still get the popup. I am not part of a domain that has policies overriding my personal device. Aug 6, 2014 at 19:59
  • The linked MSDN page does not say anything about the clipboard. It is just a list of annotated links. Jun 18 at 8:57
1

I had a similar issue, with Office 365 and Internet Explorer 11 when trying to copy from a Word document (which now opens as 'Word Online' instead of a Word document). I added the address https://Custom.sharepoint.com to the trusted site list under Internet OptionsSecurity, but I still kept getting the pop-up.

A workaround is to use Ctrl + C to copy instead of using the right mouse click and copy. The hint came from the article Why your browser doesn't like copy and paste; Rob Pegoraro, Special for USA TODAY Published 7:00 a.m. ET April 13, 2014:

Why lock them out? Your computer can't tell the difference between a JavaScript-driven action that you took, such as clicking a button in a Web app, and one that a website executed on its own and without your consent.

So that's why Google Docs will tell you to use keyboard commands instead to cut, copy or paste things in and out of a document. The keys on the keyboard (as well as Chrome's own menu items) are outside a website's control, so there isn't the same risk of a privacy or security violation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.