I had already installed Windows 8 Consumer Preview on my computer and it worked flawlessly, however, now I want to install it again. When I see the installation screen at boot the screen is completely distorted; moving the mouse or a console window leaves little colored squares and dots, long trails which stay on the screen. I suppose this has something to do with the display?

If I still try to proceed with the installation steps, it installs without a problem (although it's hard to see what's going on on the screen), restarts and then I see the Windows 8 logo. For a time being, it looks properly but then it suddenly becomes messed up and distorted (as if someone turned on a "switch") and the configuration fails with an error (can't really read it because of the messed up screen).

I've tried redownloading the Consumer Preview .iso image and writing it to another DVD but it simply doesn't work. This is nonsense; I've just bought my new computer and the installation worked more than once (without this strange bug), I've been using Windows 8 for some time before reinstalling it now.

The computer specs:

AMD Athlon II X2 260 (64-bit) 4 GB DDR3 RAM Geforce GT220 1GB Gigabyte M68MT-S2P motherboard

  • Did you change any bios settings? you might try loading default settings.
    – Moab
    Sep 17, 2012 at 19:00
  • I've already tried that, didn't work. I experience no lags in Windows XP though, no problems in any of the Linux distributions either. What's starnge is that for a moment I can see a good-looking Windows 8 logo at the boot process but then it becomes distorted.
    – Onion
    Sep 17, 2012 at 19:04
  • There are known issues with the nVidia cards and Windows 8. Try removing all video drivers and then getting the latest one off their website.
    – user3463
    Sep 17, 2012 at 19:26
  • The problem is that I can't even get Windows 8 to install - how am I supposed to do that? I'm booting the computer from the installation discs and that's when I come accross this problem. What's strange is that the same disc worked without problems (more than once!) and now it doesn't, even when I've redownloaded the iso and burned it to two other discs.
    – Onion
    Sep 17, 2012 at 19:30
  • Try the evaluation version of W8 Enterprise RTM, subscribe to technet (costs nothing) and get it for free....technet.microsoft.com/en-US/evalcenter/…
    – Moab
    Sep 17, 2012 at 20:08


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.