I do not have physical access to the wireless router that I use (shared living agreement), so I cannot connect my RasPi (Model B) to the router via Ethernet. However, I am running a Windows 7 64-bit machine that connects over WiFi and has an unused Ethernet port.

I've set up Internet sharing and bound the Ethernet port to be the device that shares the Internet, and I'm running Debian Wheezy (2012-07-15 build) on my RasPi on an 8 GB SD card. However, when I plug the Ethernet cable into the RasPi and my local Win7 box, nothing seems to work on the RasPi side.

I get tx/link lights on my Windows machine as well as the RasPi, but when I run ifconfig, I get eth0 with 12 tx packets, 0 errors, 0 dropped, etc - and no IP bound to it.

I've tried editing /cat/networking/interfaces and tried to enable eth1-9 (this seems to be a weird bug that some users report where eth0 isn't the properly bound device), but all fail when I do sudo /etc/init.d/networking restart except eth0.

Google has failed me so far - what's the next step in getting wired/shared Internet working? Bridging the devices on the Windows machine?



Figured it out - I had to edit /etc/network/interfaces with this info:

auto lo eth0
iface lo inet loopback
iface eth0 inet dhcp

The first line by default was auto lo, so I added the eth0 and restarted the networking services and it worked perfectly!

| improve this answer | |
  • i have the same problem but now when the PI boots it shows "DHCPDISCOVER on eth0 to port 67 interval 6, it tries this several times and then drops out with No DHCPOFFERS recieved. Unable to obtain a lease on first try. Exiting. Failed to bring up eth0. done. And NO internet on PI :( – Welsh King Dec 9 '12 at 0:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.