I just updated to the stable version of Cinnamon 1.6 in Ubuntu 12.04 x64, but I found a bug which just get's me out of my skin.

The key combination CtrlAltT which is supposed to open up the Terminal doesn't work.

Any ideas?

P.S. I would really like to stick with the same shortcut.

5 Answers 5


You could try creating a custom shortcut for terminal with Ctrl-Alt-T as the assigned keyboard shortcut.

Open keyboard from Menu and move to Custom Shortcuts. Add a new shortcut by clicking on the + button. Add a relevant name to the shortcut. Input gnome-terminal or Linux Mint alternative command and add the keyboard shortcut you desire.

Keyboard shortcuts

See my answer on Ask Ubuntu for reference:


This issue seems to come down to the default terminal application in cinnamon pointing to gnome-terminal instead of the terminal included by default, mate-terminal. I was not able to change the command pointed to by the keyboard shortcut configuration utility, but I was able to solve the problem:

From "System Settings", select "Preferred Applications". All fields were populated except "Terminal". Selecting the only option (helpfully named "Terminal") set the system default (presumably to mate-terminal) and fixed the keyboard shortcut problem.

Alternatively, you can use dconf-editor (or similar) to set org.desktop.applications.terminal to 'mate-terminal'.


I had a similar problem and found a solution. The distribution I've got is Linux Mint w/ Cinnamon GUI, which is offered as Debian-based or as Ubuntu-based versions. Mine's the Debian-based version, identified as 201303 presumably for March 2013, at a time when the Ubuntu-based version is named 16 Petra.

Clicking my way through menus starting at the taskbar (or whatever it's called in Cinnamon)...

Preferences -> Cinnamon Settings -> Keyboard

Here I went to put a Terminal shortcut, to use Ctrl-Alt-t for the terminal, but I see it's already there in the list from a fresh installation. Yet Ctrl-Alt-t doesn't do anything when I type it. Odd. So that's a dead end.

Going into the file manager worked. Navigate your directories to here:


and double-click the "keyboard" program in there. You cannot open the program from the command line, you have to be in a graphical file manager. If you were to try opening it from a terminal, you'd first realize the actual name of it is gnome-keyboard.desktop. There's a help page discussing how .desktop files can't be opened via a terminal: https://askubuntu.com/questions/5172/running-a-desktop-file-in-the-terminal

Anyway, once you've double-clicked it and opened it, entering your settings there works. In the left sidebar, click on "Custom Shortcuts", then click on the + sign. In the text field for Name, put Terminal or whatever you want -- the name doesn't matter. In the text field for Command, put x-terminal-emulator. Don't have a period after it, I was just ending my sentence.

Lastly, on the right side of the window is the word Disabled. Do a single click on that word (not just anywhere on the line) and it'll change to New Shortcut, at which point you can hold down the Ctrl and Alt keys and hit the letter t, to input the Ctrl-Alt-t shortcut. If nothing seems to happen, be advised that accidentally doing a double-click instead of a single click toggles it so quickly (from Disabled to New Shortcut back to Disabled), you'd be forgiven for thinking your input was ignored.

Now try using your shortcut. For me it goes into effect before even quitting the program.


Sometimes there's some interference with the "commands" compiz plugin. Deactivating it solved the issue for me:

  1. Open CompizConfig Settings Manager (ccsm)
  2. Un-tick the box next to "Commands" under the "General" section

Maybe it's because you installed another terminal like Mate Terminal or something like that .

Make sure remove all third party terminal programms .

Then gnome-terminal will launch by ALT+CTRL+T

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .