4

I have my Nexus One configured as a portable Wi-Fi hotspot named AndroidAP JD. Whenever I turn on the wifi capability and connect to it with a Windows 7 machine, it remembers the password and connects automatically. However, it will prompt me to ask if I should make "AndroidAP JD n" a work, home or public network. Why does it make a new network profile for the same hotspot?

  • hmm.. take a look at the ip address on the client - which you receive from your nexus device. maybe the address is everytime in a new range (just a guess) – Cadburry Sep 19 '12 at 13:24
  • It does the same thing for me on different devices. I'm quite interested in a solution. I never remember that it does that and drive myself nuts trying to figure it out before I see the work/home/public window. – SaintWacko Sep 19 '12 at 13:27
  • check my answer and mark it as the correct answer, please. It's the easiest way. – Zibri Nov 19 '19 at 12:17
1

Windows does quite a bit of guessing when it tries to identify "which" network it is a member of. The most common of which is using the mac-address of the default-gateway. If the MAC of your default gateway changes... it will prompt you again to identify your network.

Some portable-hotspot apps make the android-device behave as the gateway, while others pass on the gateway directly to your telco's default-gateway(s). In the first case where your phone is acting as the gateway... these are usually apps you can find from 3rd parties (like the android-wifi-teather app.) In the other-case, these are usually limited to apps provided by your telco... so they can track your tethering-usage statistics & such.

If you switch to the 3rd-party app option, your default gateway will remain a constant and Windows will be happy. If you wish to stick to your telco's app... You'll have to keep adding the network until it has added every possible default gateway your telco might have.

| improve this answer | |
  • 1
    I'm using the built-in nexus one tethering. I'll inspect the gateway IP and mac address to see if they change and look into a third party app. – Justin Dearing Sep 23 '12 at 22:39
  • Same here. Built into the AOKP ROM and every time it asks me, even when USB tethering. Really annoying. – Mark A. Donohoe Nov 19 '12 at 2:19
1

I just found an easier way to avoid windows (10) to generate a new network number and reset the settings:

Tether your phone using USB, then:
Open device manager and find "Remote NDIS based Internet Sharing Device"
Then go to properties, advanced, select network address and assign a value.

That's it.

| improve this answer | |
  • 1
    Much simpler answer, working for me so far – Calvin Li Nov 15 '19 at 21:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.