I am trying to recover some pictures on my 320 GB Hard Disk, so I put in a Live Ubuntu CD and am in that right now.

In the devices list, it shows my USB drive, but not my 320 GB Hard Disk. I can see the disk in Disk Utility (it says it's on /dev/sda), but it's not mounted, and it says it has a few bad sectors but it is OK.

In Disk Usage Analyzer, it says my maximum capacity is 13.4 GB, so it's definitely not using the 320 GB Hard Disk.

I tried the following:

sudo mkdir /media/newhd (worked)

sudo mount /dev/sda /media/newhd (didn't work. it says I must specify the filesystem type)

I then tried:

fsck.ext4 -f /dev/sda (didn't work. Said: Superblock invalid, trying to backup blocks. then: Bad magic number in super-block while trying to open /dev/sda. The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock)

Does anyone have any ideas? The whole problem started when my Windows Vista said "Can't find operating system". Any ideas on how I can get on to my hard drive at /dev/sda?

  • Try ls -l /dev/sda* to get a list of partitions on the hard drive. mount and fsck reference filesystems, which are installed into partitions, not entire hard disk drives, e.g. /dev/sda. – sawdust Sep 19 '12 at 19:57

I believe you need to mount the specific partition as in sudo mount /dev/sda1 /media/newhd.

What does sudo fdisk -l /dev/sda output say about the partition table? This will tell you if you have a valid partition table which is questionable since you are reporting only 13GB.


In addition to mbair's answer, have a look at GParted. It will show you the individual partitions, their names, and any errors, all in a much easier form to understand than fdisk or its ilk.


try this....

sudo fdisk -l

this will give you list of hard drives select one out of them

sudo mount selected drive(/dev/sda1) to /mnt

then for un mount use

sudo umount /mnt 


sudo umount selected drive(/dev/sda1)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.