11

In Windows 8 I find I can't drag files to applications like I've been able to do for as long as I can remember. Example:

  • Drag MP3s to Winamp
  • Drag folder full of music to Winamp
  • Drag videos to VLC
  • Drag txt, reg etc files to Notepad

I have tried various combinations of:

  • Running Explorer as administrator
  • Running drop target as administrator
  • Taking ownership of drop target application's folder
  • Taking ownership of Explorer
  • Changing user account to administrator
  • Create a new user account
  • Lowering UAC level
  • Disabling UAC in GUI
  • Disabling UAC in registry
  • Running Explorer folders in a separate thread

This is the last straw if there's no known proper (ie non hacky compromise) fix for this. "Little" things like this combined are a productivity nightmare and if I have to relearn so much and configure so much to get basic things done with an OS I might as well just move to Linux once and for all.

8
  • 1
    Not sure what to tell you - I'm running Windows 8 RTM and was able just now to drag and drop an audio file onto VLC (I started VLC first, it was just sitting there) and it worked perfectly.
    – Mark Allen
    Sep 21, 2012 at 2:58
  • 1
    It occasionally works for me but usually I just get a "no entry" icon when I try. Sep 21, 2012 at 4:50
  • I just went back and tried it, dragged about 8 different .mp4 files onto it. When you try it, does the icon change when you're holding the file over VLC?
    – Mark Allen
    Sep 21, 2012 at 7:34
  • Yep, the icon changes to a circle with a line through it like a no entry sign. Sep 23, 2012 at 11:26
  • 3
    Is your ESC key struck. Try tapping it and then dragging and dropping. sevenforums.com/general-discussion/15038-i-cant-drag-drop.html
    – Serious
    Oct 23, 2012 at 7:43

2 Answers 2

4

OK, finally worked out what it is. Any applications opened directly from Explorer seem to be fine. Any applications opened from an application launcher anywhere in their history (eg: Launchy, Classic Shell start menu etc) exhibit the above behaviour. Running the application launcher as Administrator mostly fixes the problem, though it still occurs infrequently and I still can't work out why.

2
  • Well, you worked how to solve it in most cases, but I personally have no idea about what it is. Anyway, I don't need to know that, but I'm very interested in knowing how can I run the application launcher as administrator. ;) Thank you.
    – Trylks
    Feb 12, 2014 at 16:22
  • 2
    Nevermind, I did this seems to be working now...
    – Trylks
    Feb 12, 2014 at 17:24
2

Sounds like the applications cannot hook into explorer.

Try to refresh the PC, which takes 5 minutes(don't forget to back up of course) and if that does not work reinstall. I know it is a sucky solution but it definitely is a software problem specific to you.

0

Not the answer you're looking for? Browse other questions tagged or ask your own question.