I try to mount an encrypted HFS+ partition in Ubuntu.

An older post described quite good how to do it, but lacks the information how to use encrypted partitions.

What I found so far is:

  # install required packages
  sudo apt-get install hfsprogs hfsutils hfsplus loop-aes-utils
  # try to mount it
  mount -t hfsplus -o encryption=aes-256 /dev/xyz /mount/xyz

But once I run this I get the following error:

  Error: Password must be at least 20 characters.

So I tried to type it in twice, but that results in this:

  ioctl: LOOP_SET_STATUS: Invalid argument, requested cipher or key (256 bits) not supported by kernel

Any suggestions?

  • Not sure if this makes a difference, but have you tried aes256 instead of aes-256? Sep 21, 2012 at 19:56
  • yes - same result for both - even just using "aes" gives the same result
    – pagid
    Sep 21, 2012 at 20:01

2 Answers 2


You can't mount an HFS+ partition encrypted in OS X using mount's option encryption=aes. The reason is that encrypted HFS+ partitions and volumes use a proprietary format.

Neither Cryptoloop nor Loop-AES, which are the underlying decryption methods used by mount and encryption, understand that format.

This is what I found out:

Cryptoloop can mount partitions or disk images encrypted as a single AES block (this is called single-key mode, see http://www.tldp.org/HOWTO/html_single/Cryptoloop-HOWTO/#cryptoloop-introduction):

  disk image                                                       /dev/loopX
+-----------+                                                    +-------------+
|           |                                                    |             |
|           |                                                    |             |
|           |                                                    | unencrypted |
| AES block | -AES passwd->AES key->decrypt I/O to loop device-> |  partition  |
|           |                                                    |             |
|           |                                                    |             |
|           |                                                    |             |
+-----------+                                                    +-------------+

AES-Loop can mount single-key (like above) and multi-key encrypted partitions or disk images:

  disk image                                                         /dev/loopX
+------------+                                                    +-------------+
|AES block #1|                                                    |             |
+------------+                                                    |             |
|AES block #2|                                                    | unencrypted |
+------------+ -AES passwd->AES key(s)->decrypt I/O to loop dev-> |  partition  |
|AES block #3|                                                    |             |
+------------+                                                    |             |
|    ...     |                                                    |             |
+------------+                                                    +-------------+

On the other hand, an encrypted HFS+ partition:

Cryptoloop's successor, dm-crypt, can't read encrypted HFS+ either.

But before all hope is gone:

As for the error messages you encountered:

First error:

Error: Password must be at least 20 characters.

Surprisingly, mount enforces long passwords not only for encryption but also for decryption, although you may not have control over the partition to decrypt. You can only get around this nuisance by downloading and editing the source and recompiling. (Other distributions, like SuSE Linux Enterprise Server (SLES), don't have this restriction.)

Second error:

ioctl: LOOP_SET_STATUS: Invalid argument, requested cipher or key (256 bits) not supported by kernel

You need to load the Cryptoloop kernel module:

$ sudo modprobe cryptoloop

because although you installed package loop-aes-utils you are not using Loop-AES.

Loop-AES uses several modified user space tools (mount, umount, losetup, swapon and swapoff, provided by loop-aes-utils) and a modified loop.ko kernel module. Recent Ubuntu versions compile an unmodified loop module into the kernel:

    $ cd /usr/src/linux-source-3.2.0/linux-source-3.2.0/drivers/block/
    $ diff -q /tmp/loop.c-3.x.patched loop.c
    Files /tmp/loop.c-3.x.patched and loop.c differ

so Loop-AES can't be used on Ubuntu out of the box. You need to patch and recompile the kernel as explained here: http://loop-aes.sourceforge.net/loop-AES.README. That's why mount still needs Cryptoloop.

If you still get a similar error message after loading cryptoloop.ko the encryption type may be not recognized. For example, my Ubuntu 12.04 didn't recognize aes-128, but aes. SLES only recognizes aes-128.

  • 1
    +1 for the in-depth information and detail provided in the answer. Nov 5, 2012 at 18:42
  • 6
    This is a simply phenomenal answer. Exceptionally informative, detailed, and apparently extremely well researched. Thanks for sharing jaume, thanks a lot.
    – chmac
    Apr 17, 2013 at 13:30
  • 3
    Just wanted to note that I've just tried this on OSX 10.10.3 with success. I also found that the process of decrypting the drive wouldn't make any progress when I was doing much with the computer. However, with the laptop on wall power and the drive plugged in, I left the lid closed (full sleep) and it finished the decryption while it slept in PowerNap.
    – voxobscuro
    Apr 23, 2015 at 1:34

Actually, there is Java application hfsexplorer that is able to open encrypted .dmg files and creates decrypted .dmg images which can be mounted in Linux.

I was able to create encrypted .dmg files in OS X 10.9.5 and then explore the image from a virtual machine running Ubuntu 14.04.2 LTS. Both AES-128 and AES-256 encryption worked for my test cases.

This is how I created the .dmg image:

$ hdiutil create -size 10m -layout NONE -fs HFS+ -encryption AES-256 -volname "Vault" vault.dmg

From the virtual machine running Ubuntu I was able to open the image:

$ ./hfsexplorer-0/bin/hfsexplorer.sh /tmp/vault.dmg

It prompts for a password and then shows the content of the image. There is an option (Tools -> create disk image) which creates an decrypted disk image which can then be mounted with the hfs tools from linux.

$ mount vault_decrypted.dmg /mnt/hfs/

Even HFS+ Journaled file systems worked. The only limitation is that the write support to HFS+J file systems is disabled by default in Linux.

This demonstrates that the encryption of .dmg is understood by hfsexplorer and could possibly be implemented in the mount command. With creating an unencrypted .dmg it is possible to mount the image in Linux ultimately.

vfdecrypt did not work for me either.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.