I am using firefox 14 and lately, I have been observing this weird problem with my firefox. Everytime I put an address in address bar and hit return, https version of the site opens. This has no problem to me but some of my the sites which do not support https can not be opened without typing full http:// followed by the site .

I am not using https enabling extension. No extensions were changed when this problem popped up.

migrated from stackoverflow.com Sep 23 '12 at 6:27

This question came from our site for professional and enthusiast programmers.

  • Are you sure it isn't the website automatically forwarding you to use https? – Gung Foo Sep 23 '12 at 5:47
  • 1
    Is this happening for all websites or some specific??? – Manjoor Sep 23 '12 at 5:47
  • @KenWhite ok.no problem mate :) – Akshat Goel Sep 23 '12 at 5:52
  • Can you try to open firefox in safe mode? From command prompt, try EITHER firefox -safe-mode or "C:\Program Files\Mozilla Firefox\firefox.exe" -safe-mode or "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -safe-mode and see if the problem persists. Does it happen to IE as well? – Dave Sep 23 '12 at 8:44
  • It can be turned off: superuser.com/questions/554399/… – sourcejedi Feb 19 '13 at 19:43

Yes! Firefox have decided to implemented https by default with firefox 14. Check out the following links:

Information week
Engadget

  • 2
    Yes, but this covers only google's sites.Not whole internet. – rkosegi Sep 23 '12 at 6:54

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.